Bug #23091 Should separate Stored Procedures Tab and User-Defined Functions Tab
Submitted: 8 Oct 2006 16:31 Modified: 17 Oct 2006 12:00
Reporter: Edward Chan Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.4 rc OS:Microsoft Windows (Windows XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: mysql administrator, stored procedure, User-Defined Functions

[8 Oct 2006 16:31] Edward Chan
Description:
MySQL Administrator should separate Stored Procedures Tab and User-Defined Functions Tab instead of only one Stored Procedures Tab. Holding two different things in the same Tab is very very messy. Except User-Defined Functions Tab, the list of Stored Procedures Tab should not show "Return Data Type" column in the list because Stored Procedures do not return data type.

How to repeat:
Click "Stored Procedures" Tab to view the list.

Suggested fix:
Should separate into two Tabs with different column shown in the list.

Stored Procedures Tab:
Should show "Routine Name", "Definer", "Created", "Modified", "Comment" in the list.

User-Defined Functions Tab:
Should show "Routine Name", "Definer", "Created", "Modified", "Return Data Type", "Comment" in the list.
[9 Oct 2006 14:24] Miguel Solorzano
Thank you for the bug report.
[17 Oct 2006 12:00] Mike Lischke
Thank you for taking the time to write to us, but this is not a bug. The SP/SF page works just like intended, because both are so similar, in fact they are almost identical (except for the return value and the possible recursion) that they don't justify an own page. Hence we put stored functions and stored procedures on the same page.