Bug #2306 memory error when starting service on windows with lower_case_table_names=0
Submitted: 7 Jan 2004 7:27 Modified: 7 Jan 2004 14:41
Reporter: Gilles Levreau Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.0.17 OS:Microsoft Windows (Windows 2000)
Assigned to: CPU Architecture:Any

[7 Jan 2004 7:27] Gilles Levreau
Description:
Starting the mysqld-nt service on Windows 2000, with the server option lower_case_table_names turned on, triggers a 'memory could not be written' error.

Debugging that error reveals that it happens when calling:
sql_print_error("Warning: Setting lower_case_table_names=1 becasue file system %s is case insensitve", mysql_real_data_home);

(this is in file sql/mysqld.cpp, line 4958)

Well, now I know I should have had this option turned off, but still. Turning that option off solves the problem, but who knows if it's not going to crash somewhere else for another warning, so I would think it's worth investing.

Workaround:
Turn off the lower_case_table_names option. According to the documentation, that's what should be done on case-insensitive OSes anyway.

How to repeat:
- Install mysql 4.0.17 on a windows machine

- In mysql configuration file, section mysqld, set this option:
set-variable=lower_case_table_names=0

- Install the service. Open a command prompt in mysql bin directory:
mysqld-nt --install mysqlopt --default-file="<path-to-my-config-file>"

- start the service:
net start mysqlopt
[7 Jan 2004 14:41] Sergei Golubchik
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in MySQL.

Additional info:

duplicate of bug#2179