Bug #23003 Can't edit routine group object
Submitted: 5 Oct 2006 7:36 Modified: 26 Oct 2006 2:37
Reporter: Hu Hailin Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench Preview Severity:S1 (Critical)
Version:1.1.4 alpha OS:Microsoft Windows (Windows XP SP2)
Assigned to: CPU Architecture:Any

[5 Oct 2006 7:36] Hu Hailin
Description:
When I tried to edit a routine group object, error occurred.

[Object Editor Error]
The following error occured while launching the object editor.
Error reading RoutineUce.MaxRightChar: Property MaxRightChar does not exist

The edition I am using:
mysql-gui-tools-noinstall-5.0-r4-win32.zip

How to repeat:
download from dev.mysql.com
mysql-gui-tools-noinstall-5.0-r4-win32.zip

extract the package
start MySQLWorkbench.exe

use the default "New Model"
use the menu at the left side to create a routine group object
edit it and error occurs
[6 Oct 2006 1:47] MySQL Verification Team
Thank you for the bug report.
[10 Oct 2006 15:21] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=23134 was marked as duplicate of this one.
[19 Oct 2006 15:24] Matteo Pisani
Same error with win XP SP2, both opening a new model and using a model imported from DBDesigner4.
[20 Oct 2006 10:34] Nicolas Laplante
Same problem here too. Windows XP SP2 + MySQL Workbench 1.1.4 alpha. Also occurs when trying to edit routine group from a reverse engineered schema.
[23 Oct 2006 9:35] Sorin Sbarnea
Real stept to reproduce: 
1 new table
2 double click on table header.

I've deleted even all configuration files from Application Data. Problem still exist and it's CRITICAL because it makes the product not usable.
[24 Oct 2006 8:31] klemen zivkovic
Bug should be changed to CRITICAL !!!
[26 Oct 2006 2:37] Hu Hailin
I agree.
[6 Nov 2006 14:49] Robert Banniza
Im using version 1.1.5 alpha. same bug occource here. 
The hole reverse engeneering task is senseless if its not possible to edit the schemata.
[11 Dec 2006 6:38] David Muir
Problem still exists with 1.1.6

The bug did not exist in 1.1.3.

Where can I get older versions? Can't find links to it anywhere.