Bug #228 Application crash when editing Data Type
Submitted: 4 Apr 2003 7:57 Modified: 21 May 2003 8:55
Reporter: Eron Lloyd Email Updates:
Status: Closed Impact on me:
Category:MySQLCC Severity:S1 (Critical)
Version:0.9.1 OS:Linux (SuSE Linux 8.1 (x86))
Assigned to: Bugs System CPU Architecture:Any

[4 Apr 2003 7:57] Eron Lloyd
Every time I try to edit the Data Type of a column, the whole program  
segfaults. I've tried it on two different linux boxes, each running SuSE 8.1,  
glibc 2.2, and either MySQL 4.0.10 or 4.0.12. It doesn't seem to matter what  
type of table it is, or whether I'm creating or editing an existing table.  
Older versions (0.8.x) seem to have worked properly, but the 0.9.x series  
doesn't. Several times, the drop box will display, with a large amount of space 
above the list items, and then will crash. 

How to repeat:
From within MySQLCC, connect to a database, and select a table to edit. In any of 
the column entries, select the Data Type drop-down box, which will promptly 
produce a segfault and the program will exit.
[21 May 2003 8:55] Jorge del Conde
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at