Bug #22780 Query Browser Comment recognition fails if space doesnt follow after --
Submitted: 28 Sep 2006 12:24 Modified: 13 Dec 2006 13:29
Reporter: thomas menzel Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.2.3beta OS:Microsoft Windows (win32)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: comment, parsing, SQL Syntax

[28 Sep 2006 12:24] thomas menzel
Description:
Query Browser Comment recognition fails if space doesnt follow after --

this SQL fails in QB:
SELECT * FROM mysql.host h
--order by h.Insert_priv

this works:
SELECT * FROM mysql.host h
-- order by h.Insert_priv

when using the first statement with another client (eg. eclipse plugin DB edit) it works, so it's not an egine problem.

i first thought to put this on S3 but chnaged my mind, since when you have already some SQL stmts and you want to execute them in QB you must edit them if they contain comments like in stmt 1 and this can be a pain in the A...

How to repeat:
s.a.
[28 Sep 2006 12:43] Valeriy Kravchuk
Verified just as described on XP.
[13 Dec 2006 13:29] Mike Lischke
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Look particularly here:
- http://dev.mysql.com/doc/refman/5.0/en/comments.html
- http://dev.mysql.com/doc/refman/5.0/en/ansi-diff-comments.html