Bug #22630 Err No. 2003: MySQL server 5.0.24a Won't start! Unknown reason..
Submitted: 23 Sep 2006 13:26 Modified: 23 Sep 2006 17:31
Reporter: [ name withheld ] Email Updates:
Status: Closed Impact on me:
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.24a OS:Windows (Windows XP Professional)
Assigned to: CPU Architecture:Any
Tags: ?

[23 Sep 2006 13:26] [ name withheld ]
I downloaded this mysql server from the mysql website. It was working at first but somehow it doesnt work anymore. I have tried disabling my windows firewall but it still won't connect. I have tried using the sc start mysql function from command line but it says start_pending but won't start. I have also tried starting mysql from Control Panel-> Adminstration -> Services -> MySQL -> Start but it brings up an error saying the mysql server failed to start. I would like to know what is the cause of this problem? Is there another firewall on my pc which I don't know about? How do I find out I have another firewall.. Or is it another problem?

How to repeat:

Suggested fix:
Disabling a firewall? Port problem?
[23 Sep 2006 15:39] Peter Laursen
it is likely that something's wrong with your my.ini -file.
Try using one of the 'templates' (my-large.cnf, my-medium.cnf etc)found in the installation directory,  rename to 'my.ini' (NOT 'my.ini.conf' or 'my.ini.txt' !) and try restarting the server.

The installer/cunfigurator builds a my.ini, but it is seen before that something went wrong!
[23 Sep 2006 17:31] [ name withheld ]
I should have said this before. I did uninstall mysql and install it again and it still didnt work. But I uninstalled it again, got rid of the whole mysql folder and installed it again. Then on installation, it brought up an error saying mysql connect connect, please make sure firewall is off. And I did that and now it works. I guess the whole problem was to do with the windows firewall but Im not sure why it didnt work before when I swithced the firewall off. I have also now added the port 3306 to the firewall. It could be the problem was somewhat to do with the databases folder ie data because I think I messed up the "mysql database" which comes with mysql at first, I mixed it up with a previous version of mysql. Any how the problem is solved and I would like to thank you for your help.