Bug #22563 MySQL service won't start on Vista without elevated privileges
Submitted: 21 Sep 2006 19:22 Modified: 11 Feb 2008 21:18
Reporter: Elliot Murphy Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0, 5.1 OS:Microsoft Windows (Windows Vista)
Assigned to: Iggy Galarza CPU Architecture:Any
Triage: D1 (Critical)

[21 Sep 2006 19:22] Elliot Murphy
Description:
From: "Virginia Thompson (Kelly Services Inc)" <a-vithom@microsoft.com>
Date: September 21, 2006 12:49:36 PM EDT
To: <elliot@mysql.com>
Cc: Matt Baddeley <matt.baddeley@microsoft.com>, "Christine Rice (Volt)" <a-crice@microsoft.com>, "Sue Tinney (Volt)" <a-suet@microsoft.com>
Subject: MySQL 4.1: Windows Vista incompatibility found

 
 
Hello,
 
I am working with the Windows Core Development Team at Microsoft to inform you of a product incompatibility with Windows Vista. One of our commitments is to provide the best possible end user experience for each new version of the Microsoft Windows operating system.  Microsoft regularly tests numerous software titles for compatibility purposes and in doing so we are able to identify and often address compatibility issues.
 
I am contacting you because we have identified and taken action on some compatibility issues related to your application.
 
No further action is needed on your part.
 
During our testing of:
 
 MySQL 4.1,
 
We discovered an issue which we have addressed with a Compatibility Solution.  Following are details:
 
Description of the issue:
 
Not able to start windows service when not elevated
 
Compatibility Solution:
Depending on the issue, there has been applied either a ‘shim’ solution, which is a workaround that allows your program to run seamlessly for the user, or an ‘appshelp’ solution which will display an informational dialog with a link to an appropriate page at your website.
Our Compatibility Solution will be disabled if you change any of the attributes specified in the XML code with any patches, revisions, and/or future versions of your product.  Therefore, when you resolve the issue in future application builds or updates, you will suppress our Compatibility Solution.
 
The following XML code contains the Compatibility Solution and matching information applied to your application:
 
<APP NAME="MySQL" VENDOR="MySQL" ID="{8FE90B86-146C-4910-92E7-296F05991D0B}">
        <EXE NAME="MySQLInstanceConfig.exe" MATCH_MODE="ADDITIVE" UPTO_LINK_DATE="11/01/2006 00:00:00" ID="{30B152D3-80F6-41BE-9954-2287D613E9BF}">
            <MATCHING_FILE NAME="libmySQL.dll"/>
            <MATCHING_FILE NAME="mysqladmin.exe"/>
            <FLAG NAME="RunAsAdmin"/>
        </EXE>
    </APP>
 
Key:
<APP NAME> - Your application name
<VENDOR> - The application’s ISV provider
 
For Installation Issues: 
<MSI_PACKAGE NAME> - for installer issues, the name of the installation file
<MSI_TRANSFORM NAME> - the Microsoft replacement installer package
 
For Runtime issues – Note that these issues depend on the “properties” of the target file to uniquely identify its version: 
<EXE NAME> - Executable for run time issues
<COMPANY NAME> - Name of company specified in the .EXE or .DLL
<PRODUCT VERSION> - Information about the specific version or versions that are to be acted upon
<OS_VERSION> - GTE5.1 means Greater than or Equal To Windows 5.1 (Windows XP)
< UPTO_LINK_DATE> - Date of the executable’s Link Date
<UPTO_BIN_PRODUCT_VERSION> - Version of Executable (if specified)
<BIN_FILE_VERSION> - Binary File Version
<MATCHING_FILE NAME> - Used when the <EXE NAME> does not contain a version number
<SHIM NAME> - the name of the internal process designed to work around the issue.
 
Further information that you may find useful:
 
Application Compatibility Cookbook:
Microsoft is compiling a list of Windows Vista compatible applications, and we will be sharing that list with consumers through the Windows Vista Upgrade Advisor and our enterprise customers through the Application Compatibility Toolkit.  As Windows Vista RC1 is available, you can register your applications to be visible through these tools, and get the rights to use the Works with Windows Vista logo.  
 
http://msdn.microsoft.com/windowsvista/reference/interop/default.aspx?pull=/library/en-us/....
 
Vista Developer Forum:
Follow this link to access online conversations where you can read about and discuss application compatibility testing, common compatibility issues, and best practices for Windows Vista.
 
http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=904&SiteID=1
 
Shims/appshelp:
For more detailed information about application compatibility technologies, including shims and appshelp, see this white paper:
 
http://www.microsoft.com/technet/prodtechnol/winxppro/plan/appcmpxp.mspx
 
Application Compatibility and 64-bit technology
Windows Vista™ has a compatibility layer that allows most legacy applications to run without modifications.  This technology does not provide any support for 16-bit binaries (most commonly installers) or 32-bit drivers or kernel components on 64 bit versions of Windows Vista™.  Therefore, applications that depend on 16-bit binaries or 32-bit drivers or kernel components (in the case of 64-bit versions) cannot run on Windows Vista™ unless the application vendor provides a compatibility patch for the application (32-bit installer, and/or 64-bit driver versions).
 
If you are not the appropriate contact person for this issue, could you please refer me to correct person and forward this email to them?
  
Thank you,
~Virginia
 
Virginia Thompson | Program Assistant | Kelly Services Inc.
Windows Partner Engagement | Microsoft Corporation
One Microsoft Way | Redmond, WA | 98052-6399 
* a-vithom@microsoft.com   Bug ID: 1843618
 
 
Please note that Microsoft’s® testing services and the Compatibility solution are provided “as-is” without warranty of any kind, and Microsoft® disclaims all warranties, whether express, implied or statutory. In addition, MICROSOFT® shall not be liable for any indirect, consequential, incidental, punitive, special, or other damages, even if MICROSOFT® has been advised of the possibility of such damages. MICROSOFT SHALL HAVE NO OBLIGATION TO MARKET, SELL, OR OTHERWISE DISTRIBUTE AN APPLICATION COMPATIBILITY SOLUTION, EITHER ALONE OR IN ANY MICROSOFT PRODUCT.

How to repeat:
Use vista.
[21 Sep 2006 21:02] Elliot Murphy
The issue that Virginia reported to you was fixed in a current Vista build with the RunAsAdmin shim as shown in the fix .xml included in the notification email, so your users of the released version of the Vista operating system are unaffected by the original problem reported in the bug.
 
The steps to reproduce the reported problem before the fix were:
 
1. Install MySql using default options
2. On MySQL setup wizard select to Skip Sign-up and click on Next button
3. Select Finish button to complete setup
4. Go through MySQL Configuration Wizard selecting defaults (make sure Install as Windows Service is selected)
5. At the end of Configuration select to create Anonymous Account and enter a password and select Next button
6. Click on Execute button
 
Expected Results: Configuration selected by the user gets executed
 
Actual Results: Configuration wizard fails to start MySQL Windows Service
[22 Oct 2006 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 Nov 2006 14:37] Daniel Edney
I have managed to solve the mysql and vista RC1 service start problem with a .bat file. 

You can view it on my blog

http://tagworld.com/php3ch0/PostDetail.aspx?id=463b0abb-c19c-4077-93b7-33a12e6373c0
[14 Nov 2006 21:43] Timothy Smith
Daniel,

Thank you for the batch file.  I hope it is a useful workaround until MySQL is modified to work without it.

Regards,

Timothy
[25 Nov 2006 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[29 Nov 2006 19:59] Iggy Galarza
I downloaded and attempted to install MySql-4.1.22-Community Edition on a machine running Windows Vista RTM and got the expected results not the error.
[30 Dec 2006 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 Apr 2007 0:02] Eject Disc
Same problem in starting the MySQL service on Windows Vista.

I am using: mysql-essential-5.0.37-win32.msi

I got around the problem by using the .bat file as listed above Daniel Edney.

More details about my Vista system: 
Windows Vista Home Premium
1Gb RAM, 
Intel Core 2 Duo T5500 @ 1.66Ghz
32-bit OS
Version 6.0.6000
[10 Aug 2007 14:45] Iggy Galarza
Now that bug#24732 has been pushed all of the server executables include a manifest which requests the execution level of "AsInvoker" making this bug no longer an issue for those executables.
[12 Sep 2007 16:37] Thanapm Chaikiti
Install MySQL 4.023 on Windows Vista HOME not service mysql in 
Administrative tools -mysql not show in start and stop
and MySQL not connect to database
[19 Dec 2007 20:15] Patrick Crews
Verified that the MySQLInstanceConfig.exe file has a digital signature tab as intended.
[11 Feb 2008 21:18] Paul Dubois
Noted in 5.0.51a, 5.0.56 changelogs.

For Windows Vista, MySQLInstanceConfig.exe did not include a proper
manifest enabling it to run with administrative privileges.
[2 Apr 2008 21:06] Lucas Heuman
Closed but yet to be addressed in latest version.
[8 Jun 2008 4:26] bob eff
use the sc create command in a dos window to add the service manually:

sc create MySQL start= auto DisplayName= MySQL binPath= c:\program files\mysql\mysql server 5.1\bin\mysqld.exe

then if you need to alter any parameters, use the administrative tools/services utility