Bug #22501 MySQL plug For VS2005 Alpha {MySql Database] Missing MySql Database option
Submitted: 20 Sep 2006 0:23 Modified: 3 Oct 2006 19:43
Reporter: Mark Rowe Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:Alpha OS:Microsoft Windows (Windows XP/Windows Server 2003)
Assigned to: CPU Architecture:Any

[20 Sep 2006 0:23] Mark Rowe
Description:
While the plugin works properly with the Tools-> Connect to Database 
   When I try to drag and Drop a table from the Server view it will not "Auto Synch" like ODBC and Sql Does, at the moment it only seems that it is useful as a substitute for MySql Query Administrator. 

If you Drag a datagrid to the screen then try to map it to a MYSQL database it will not give you the option to do so and give an error of. 

When I try to point it to the one I set up via Tools->Connect to Database the MySql Database option is present. It connects perfectly. 

When using as a smart tag from a newly made DataGrid if I point to an existing connection I made with "Connect to Database", then I continually get a: 

The data provider'MySql.Data.MySqlClient' could not be found in the the system configuration. Failed to find or load the registered .Net Framework Data Provider. 

Futhermore, I can't make a new MySql Database connetion because the option isn't there. 

Basically it works in one part but not in others. 

How to repeat:
Create a connection to a server and lock it in. 

Then pull a datagrid to a form 

From there use the dropdown to select your connect (It won't give you that option)

Or

Try to drag a table from the server explorer onto a form.

Suggested fix:
If I could get eh source code I would be happy to look into it though I am unsure of the plugin hooks for 2k3/5 though I knew them for VISUAL studio 6
[3 Oct 2006 19:43] Reggie Burnett
This is expected behavior for 1.0.  We will be supporting more application design features in 1.1