Bug #2230 Binary 4.1.1 install on OSX Panther does not fully function
Submitted: 28 Dec 2003 22:20 Modified: 6 Jan 2004 3:12
Reporter: Paul Bennett Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S1 (Critical)
Version:4.1.1 OS:Mac OS X (OSX Panther)
Assigned to: Assigned Account CPU Architecture:Any

[28 Dec 2003 22:20] Paul Bennett
Description:
Re: MySQL 4.1.1 install on Mac OSX 10.3.*
I'm a newbie so take this with consideration - but the multiple attempts at installng this version using the binary install provided left me with what seemed to be reduced privileges.
Once in mysql the command USE [database]  would work fine. Other commands such as SHOW [databases][tables], CREATE, or most other commands I tried would not work. It would always return an error ...
ERROR: No query found

Which is the same error it returned if I misstyped a command. However, outside of mysql if I ran mysqlshow, the databases all showed up!!

How to repeat:
Clean install of Panther
Install Mac version of MySQL 4.1.1
Complete install by ./mysql_install-db  [NOTE: the binary does not do this for you]
Ensure data directory has correct privileges for user 'mysql', therefore...
   chown -R mysql data/
./mysqld_safe --user=mysql &
./mysql test
-> SHOW databases;

Suggested fix:
No idea - I'm new at this. However - it might be the way the binary install is performed!?
[6 Jan 2004 3:12] Lenz Grimmer
Thanks for reporting this - this is a duplicate of Bug #2058