Bug #22251 Shared compatibilty library RPMs are incomplete (5.0.24a)
Submitted: 11 Sep 2006 22:52 Modified: 26 Sep 2006 8:19
Reporter: Adam Batkin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.24a OS:Linux (RHEL3 (Linux, glibc 2.2))
Assigned to: Joerg Bruehe CPU Architecture:Any
Tags: compat, libmysqlclient, rpm

[11 Sep 2006 22:52] Adam Batkin
Description:
The 5.0.24 shared-compat RPMs provided (among other things) libmysqlclient.so.{10,12} but the 5.0.24a RPMs do not. This is a problem for libraries compiled against the older versions.

rpm -qlp MySQL-shared-compat-5.0.24-0.rhel3.i386.rpm
/usr/lib/libmysqlclient.so
/usr/lib/libmysqlclient.so.10
/usr/lib/libmysqlclient.so.10.0.0
/usr/lib/libmysqlclient.so.12
/usr/lib/libmysqlclient.so.12.0.0
/usr/lib/libmysqlclient.so.14
/usr/lib/libmysqlclient.so.14.0.0
/usr/lib/libmysqlclient.so.15
/usr/lib/libmysqlclient.so.15.0.0
/usr/lib/libmysqlclient_r.so
/usr/lib/libmysqlclient_r.so.10
/usr/lib/libmysqlclient_r.so.10.0.0
/usr/lib/libmysqlclient_r.so.12
/usr/lib/libmysqlclient_r.so.12.0.0
/usr/lib/libmysqlclient_r.so.14
/usr/lib/libmysqlclient_r.so.14.0.0
/usr/lib/libmysqlclient_r.so.15
/usr/lib/libmysqlclient_r.so.15.0.0

rpm -qlp MySQL-shared-compat-5.0.24a-0.rhel3.i386.rpm
/usr/lib/libmysqlclient.so
/usr/lib/libmysqlclient.so.14
/usr/lib/libmysqlclient.so.14.0.0
/usr/lib/libmysqlclient.so.15
/usr/lib/libmysqlclient.so.15.0.0
/usr/lib/libmysqlclient_r.so
/usr/lib/libmysqlclient_r.so.14
/usr/lib/libmysqlclient_r.so.14.0.0
/usr/lib/libmysqlclient_r.so.15
/usr/lib/libmysqlclient_r.so.15.0.0

This is similar to the (old and now closed) Bug 21341

How to repeat:
Download RPMs from http://dev.mysql.com/downloads/mysql/5.0.html

Suggested fix:
Rebuild RPMs with the missing libraries included
[12 Sep 2006 4:57] Matthew Montgomery
Bug is verified.

In the mean time use previous release of this package found here:
http://downloads.mysql.com/archives/mysql-5.0/MySQL-shared-compat-5.0.24-0.rhel3.i386.rpm
[20 Sep 2006 12:34] Valeriy Kravchuk
Bug #22498 was marked as a duplicate of this one.
[21 Sep 2006 17:00] Lawrence Holtsclaw
The binary compatibility (ABI) problem addressed by the 5.0.24a release is needed to keep Connector/J from crashing OpenOffice. Using the suggested release package as a work-around will not help. In light of this, I'd hardly call the issue "non-critical."
[22 Sep 2006 5:52] Mark Matthews
I'm curious how the shared compatibility RPMs relate to Connector/J, since it's 100% Java? Are you referring to either Connector/ODBC or to the built-in mysql driver for OpenOffice instead?
[22 Sep 2006 5:52] Mark Matthews
I'm curious how the shared compatibility RPMs relate to Connector/J, since it's 100% Java? Are you referring to either Connector/ODBC or to the built-in mysql driver for OpenOffice instead?
[22 Sep 2006 9:28] Joerg Bruehe
Sorry about the problem, it is fixed now.
For MySQL 5.0.25, complete "shared compat" RPMs have been built.

In case somebody is interested about the cause:
It was no tool change, it was a cleanup action in the download area!

Details:
- The "shared compat" RPMs are built by automatically extracting the required 
  libraries from the "shared" RPMs of older versions, as found in the download 
  area.
- When doing this extract, it is checked that the dependencies are the same,
  so that a "shared compat" RPM intended for a glibc 2.2 system does not
  by accident includes an older lib which is based on glibc 2.3.
- There was a bug in building both 4.0.26 and 4.0.27 that caused all their
  "shared" RPMs to be based on glibc 2.3, even those intended for glibc 2.2.
  The check mentioned above would then ensure the 4.0.25 RPMs are used as input.
- Between building 5.0.24 and 5.0.24a, a cleanup in the download area made 
  the 4.0.25 "shared" RPMs disappear from the download area, go to the archive.
  As a result, there were no 4.0 RPMs based on glibc 2.2 available ...
- The 4.0.25 "shared" RPMs have now been linked back into the download area,
  so they are used again for "shared compat".
[22 Sep 2006 10:31] Joerg Bruehe
We have decided to repeat the build of "shared compat" RPM packages in 5.0.24a, to fix this bug.
I will do that later today, then sign and uplink them.
I expect mirror propagation to start this evening (European time).
[22 Sep 2006 14:05] Joerg Bruehe
The affected "shared-compat" RPMs have been built, signed, and uplinked,
they now propagate to the mirror servers.
They can be detected by the RPM build release "1".
File names:

MySQL-shared-compat-5.0.24a-1.glibc23.i386.rpm
MySQL-shared-compat-5.0.24a-1.i386.rpm
MySQL-shared-compat-5.0.24a-1.rhel3.i386.rpm
MySQL-shared-compat-5.0.24a-1.rhel4.i386.rpm
MySQL-shared-compat-5.0.24a-1.sles9.i586.rpm
[25 Sep 2006 17:14] Paul Dubois
Noted in the 5.0.24a changelog:

The shared compatibility RPM files were missing some files.

Resetting bug report to NDI in case this must be merged
to 5.1.x.  If not, please just set the report to Closed.
[26 Sep 2006 8:19] Joerg Bruehe
5.1 is not affected - no code or tool change to fix it, just revert a too aggressive cleanup in the download area.

See my first entry of Sep 22 for a detailed explanation.