Bug #22232 mysql-test-run fails if ndb is not included in the build
Submitted: 11 Sep 2006 10:31 Modified: 13 Sep 2006 17:55
Reporter: Marko Mäkelä Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S7 (Test Cases)
Version:5.1-bk OS:
Assigned to: Magnus Blåudd CPU Architecture:Any

[11 Sep 2006 10:31] Marko Mäkelä
Description:
This changeset broke mysql-test-run.pl if the mysqld build lacks ndb support:

http://mysql.bkbits.net:8080/mysql-5.1/cset@1.2255.39.2

The problem is that mtr_path_exists() treats "file not found"
as a fatal error.

How to repeat:
BUILD/compile-pentium
make test

Suggested fix:
Replace the mtr_error() in mtr_path_exists() with warn(), or add a parameter to mtr_path_exists() for ignoring "path not found", or replace the added mtr_path_exists() in the changeset with (-e ).
[13 Sep 2006 9:43] Magnus Blåudd
Pushed to 5.1
[13 Sep 2006 9:46] Magnus Blåudd
Pushed a fix that uses 'mtr_file_exist' to check if the ndbapi_simple program has been compiled.
[13 Sep 2006 17:55] Paul Dubois
No changelog entry needed.