Bug #21871 information_schema = DoS ?
Submitted: 28 Aug 2006 12:21 Modified: 28 Aug 2006 14:11
Reporter: Tordjman Yohan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.24 OS:Linux (linux)
Assigned to:

[28 Aug 2006 12:21] Tordjman Yohan
Description:
any query like "select * from `information_schema`.`TABLES`" does a readdir on the data directory of mysql.

We have more than 10k dbs per server.

This readdir is awfull.

Cf. http://bugs.mysql.com/bug.php?id=19588 ( everyone don't care about ?? )

How to repeat:
have a real mysql server , with users, dbs and tables & do:

select * from `information_schema`.`TABLES`

Do that 15 times simultaneously & your server is out .... 

Suggested fix:
- do not do a readdir on the mysql data directory if the user is not a "superuser" and report only the information for his db

Do something serious like 

safe_show_database
skip_show_database
[28 Aug 2006 14:03] Miguel Solorzano
Thank you for the bug report. Duplicate of bug:
http://bugs.mysql.com/bug.php?id=19588
[28 Aug 2006 14:11] Tordjman Yohan
For sure it's a duplicate.

Since 4 month and nothing about it.

Anyone don't care about ? Anyone have real big servers like us ?