Bug #21651 mysqld crash at my_tz_find_with_opening_tz_tables
Submitted: 15 Aug 2006 10:58 Modified: 4 Dec 2009 14:13
Reporter: Sveta Smirnova Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.0.24, 5.0.72sp1 OS:Linux (Linux 2.6.9-5.ELsmp (RHEL))
Assigned to: CPU Architecture:Any

[15 Aug 2006 10:58] Sveta Smirnova
Description:
Slave is randomly crashing when issues different queries from relay log.

Resolved stack trace:

0x8177318 handle_segfault + 356
0x4438b8 (?)
0xa8cd32d8 _end + -1603162136
0x8265658 _Z33my_tz_find_with_opening_tz_tablesP3THDPK6String + 100
0x81ea3e1 _ZN15Query_log_event10exec_eventEP17st_relay_log_infoPKcj + 937
0x81ea034 _ZN15Query_log_event10exec_eventEP17st_relay_log_info + 24
0x8250182 _Z20exec_relay_log_eventP3THDP17st_relay_log_info + 610
0x824df17 handle_slave_sql + 999
0x43d3ae (?)
0x2abaee (?)

Quote from error log:

mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=1
max_connections=100
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 225791 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x8c786b0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xa8cd291c, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x8177318
0x4438b8
0xa8cd32d8
0x8265658
0x81ea3e1
0x81ea034
0x8250182
0x824df17
0x43d3ae
0x2abaee
New value of fp=(nil) failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x8cabcbb = update session set date_locked = '0000-00-00 00:00:00', compression='gz', session_info='x\uffff\uffff}]w\u01ce\uffff_\uffff\uffff\uffff}If\uffff\uffff\uffff\uffff-\uffffc\uffff\uffffP\uffff=\uffffKVK\uffff%F\uffffCQ\uffff8s\uffff\uffff@5\uffff\uffff\uffffB
­æ$ÉMQ\u240dW£
µ\u250c\u250cMW¦«_\u23baÖÕ\u2265ú¯ê\u240b\u2260ú?7O¥\u2265úÃÙòú£µøôë\u2260\u2534³þáÕS÷ô°O=üA¥\u252c§?,ªëé¯7Ëüüæ)þJ0õOðñé\uffff\uffff\uffffj6_V\uffff\uffff\uffff\uffff\uffffS\uffff\uffff\uffff\uffff\uffff\uffff\uffff\u03eb\uffff\uffff\uffff\uffff\uffff\uffff2\uffff\uffff\uffff_?\uffff\uffff\uffff\uffff\uffff\uffff(x\u06eb\uffff\uffff\ufffft\uffff\uffff\uffff\uffff\uffffk\uffffIf[?\uffff\uffff\uffffa\uffff=\uffff\uffffd1[\uffffI\uffff\ufffft\uffff\uffff;\uffff\uffffA\uffff\u0593\uffff\'_/M\uffff\uffff\u5053c~\uffff\u057dz\uffff\u04d3\uffff\uffff\uffffr\uffff~\uffff\uffff\uffff<\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffffwv\uffff\uffff?p7O\uffff\uffff\uffff\uffff\uffffb\uffff^J\uffff#\uffff\uffff\uffff\uffff\uffff//f\uffff\u035f\uffff\uffff\uffff\uffff\uffff\uffff\uffff\u053f\uffff\uffff\uffff\uffff\uffffOV\uffff\uffff\uffffj}\uffff\uffff\uffff\uffff\uffff\uffff\uffffZ\\\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff7\uffffn\uffff\uffff\uffff\uffffW\u02e7?\uffff\uffff_\uffff\uffff\uffffl\r\uffff\uffff\uffffzy~;\uffff\uffff\uffff\uffff\uffffT\uffff_o\uffff\u025d\uffff\uffff\uffff\u061b\uffff\uffff\uffffj\uffff\uffff\uffff\uffff\uffffgX\uffff\uffff\ufffft\u047f\uffffgxmp\uffff\uffff\uffff\uffff+/\uffff?\uffff\uffff\uffff\uffff\uffff[
\uffff\uffff<\uffffW}\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffffl\uffff\uffff\uffff\uffff\u5bdb\uffff\uffff\uffff\uffffe>\uffff\uffff\uffff~<\uffff\uffff\uffff<\uffff\uffff\uffff\uffff\uffffH\u05b7\uffff\uffff\uffff\uffff]\uffff\uffff1\uffff1\uffff\u04be\uffffN\uffff\uffff\uffff\uffff\uffffW\uffff\uffff\uffffO\uffff_\uffff\uffff\uffff\u04ef\u05af\uffff\uffff\uffff\uffff\uffff;\u075c\\uffff\u0745K\uffff\uffff\uffff\uffff=\uffff\uffff\uffff=c4\uffff\uffff\uffff|o^\uffff\uffff\uffff\uffffy\\\uffff\u0374\uffff\'\uffff\uffff3\uffff\uffff\uffffq+\uffff
\uffff~\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff
?b\uffff\uffff\uffff\ufffff\u06cap\uffff;\uffff~\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff<i\uffff{2\uffffx\uffff\uffff\uffff\uffffO\uf9db\uffff\uffff\uffff\uffff\uffff\r\uffff\'bs\u076b\uffff\uffff\uffff\uffff\uffffS\0\uffff:y\uffff\uffff\uffff\"\u0537\uffff\uffff\uffff\uffff\uffff\u07ea\u07bf\uffff\uffff\u03aa\uffffl\uffff\uffff|\\\uffff\u6b1b\u87c8\u4e04\u5caa\u8c7b\u6024\u2d60\u6bae\u170b\u5d95\u7616\u7837\u87ca\u6f00\u8849\u7b72\u5b6f\u077f\u6e2a\u7780\u7616\u8946\u6b04\u104a\u093b\u1d70\u7636\u5f06\u2c6f\u1e74\u2960\u8cc6\u6504\u7705\u761b\u2164\u82ed\u0e5e\u7b76\u96d2\u2605\u572a\u602d\u90c7\u59c3\u7f75\u717b\u8957\u1704\u2f41\u8849\u627f\u6435\u80cd\u8a97\u685b\u3410\u7f21\u441d\u1961\u010d\u703b\u1e5f\u4e13\u216e\u2e05\u0d74\u1314\u3f09\u4518\u6404\u7b26\u7d60\u7b76\u7524\u470d\u7759\u6013\u7762\u832d\u0b6b\u756d\u8957 \u85a7\u1251\u5b1b\u3313\u8918\u4105\uffff*o#\uffff\uffff\uffff\uffff\ufffft\uffff0\uffff\uffffNx\uffff\u0258H\uffff\uffff$\uffff\uffff\u0388\uffff\uffffQ|\uffff\uffff\uffff\uffff\uffff\u0170O
thd->thread_id=5
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
Description is currently collapsed. Click to expand.

How to repeat:
Set up replication.
[15 Aug 2006 20:51] Sveta Smirnova
The Time Zone tables have installed.
[18 Aug 2006 7:13] Sveta Smirnova
After upgrade to 5.0.24 crash happens every time slave restarts.
[26 Aug 2006 10:42] Valeriy Kravchuk
Thank you for a bug report. Please, send the results of SHOW CREATE TABLE and SHOW TABLE STATUS for the session table mention in the error log. Are you sure there is no NUL char (0x00) in that data you got from the relay log? Are you sure that timezone tables are correct? (see Bug #21208, for example).
[28 Aug 2006 7:42] Sveta Smirnova
CREATE TABLE session ( 
	session_id   	varchar(32) NOT NULL,
	date_created 	datetime NULL DEFAULT '0000-00-00 00:00:00',
	date_modified	timestamp NULL DEFAULT CURRENT_TIMESTAMP,
	date_locked  	datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
	session_open 	tinyint(4) NOT NULL DEFAULT '0',
	compression  	enum('none','gz','bz') NOT NULL DEFAULT 'none',
	session_info 	mediumblob NOT NULL 
	);

But error happens periodically in queries on different tables.

Timezone tables are correct and created on Linux.
[23 Sep 2006 12:24] Sveta Smirnova
Looks like problem is thread library, so I changed severity, because there is workaround.
[22 Feb 2008 23:54] Sveta Smirnova
Set to "Can't repeat" as problem is not repeatable in our environment.
[4 Dec 2009 14:13] MySQL Verification Team
i got nowhere with analyzing or repeating this.
[12 Oct 2010 8:50] MySQL Verification Team
might have been fixed when bug #9953 was fixed, in 5.1