Bug #2165 difficulty building mysqlcc on Solaris 8
Submitted: 18 Dec 2003 16:56 Modified: 1 Jun 2004 0:33
Reporter: William Croft Email Updates:
Status: Closed Impact on me:
Category:MySQLCC Severity:S2 (Serious)
Version:0.9.4-beta OS:Solaris (Solaris 8)
Assigned to: Bugs System CPU Architecture:Any

[18 Dec 2003 16:56] William Croft
It took me some hours to figure out how to build mysqlcc from source on Solaris 8 using gcc.  I am NOT a Qt or 'configure' / autoconf developer, so I found the error messages quite cryptic.  And your script seems to be broken as far as QMAKESPEC goes.  Searching various places including this bug list turned up no advice.

I would add "User Comments" to the mysqlcc manual section on installation, but I see no way of doing that.  Below is my script that finally worked for me.  Maybe you can have a platform addendum on your install section...

Frankly, I'd prefer if you just bundled in mysqlcc with the mysql binary!!

How to repeat:
Just try to "./configure", it will abort with:

checking for "/usr/local/mysql/lib/libmysqlclient.a"... yes

checking for mysql_real_connect in -lmysqlclient... no

configure: error: Could not find libmysqlclient in '/usr/lib /usr/lib/mysql                    /usr/local/lib /usr/local/lib/mysql /usr/local/mysql/lib'

Then when you finally realize it's because of the missing socket libraries, and fix that with LDFLAGS, qmake will die with:

Creating Makefile with qmake

Failure to read QMAKESPEC conf file /usr/local/qt/mkspecs/solaris2.8/qmake.conf.

Error processing project file: /space/home/croft/blue/mysqlcc-0.9.4-src/mysqlcc.pro

qmake failed, aborting

This is because QMAKESPEC is set wrong in your script.

Suggested fix:
# make mysqlcc on Solaris 8, need socket libs, and math lib
export LDFLAGS="-lsocket -lnsl -lm"
# qt stuff
export QTDIR=/usr/local/qt
export PATH=$QTDIR/bin:$PATH
export MANPATH=$QTDIR/doc/man:$MANPATH
export QMAKESPEC=$QTDIR/mkspecs/solaris-g++
# do it, please...
echo rerunning qmake, configure script has wrong QMAKESPEC for gcc
qmake mysqlcc.pro
echo now running make
[1 Jun 2004 0:33] Jorge del Conde

MySQLCC has been discontinued and will not be developed nor maintained anymore with the exception of Critical bugs.

In the near future we will release the substitute of MySQLCC called MySQL Query Browser.
[10 Feb 2006 18:21] Me Here
Oh yeah, the mysql query browser is really a replacement for the mysql control center.

Now, instead of using 1 application to build databases and view contents of a database, I have to use 2 (MySQL Administrator and MySQL Query Browser). Further, in MySQL Control Center, you can view multiple servers at once. Now you have to set up a new instance for each server you want to work with. On top of that, password saving doesn't work on any version I've tried (win2k, winxp or *nix), which makes it that much more of a pain.

I was always of the mind that when you created software to replace older software, it was supposed to be better than the software it was replacing. These two answers to replace the single MySQL Control Center are a joke - you'd be better off using phpMyAdmin.

Personally, I've been keeping a win2k up just so I can continue to use mysqlcc. If I had the time, I'd fork mysqlcc for Linux - and still might.

It just blows my mind that you had such a small, fast, versitile, coherent application and just dumped it to create these other two cumbersome, non-intuitive applications.

Sorry about the rant, I've been looking for a place to say this for almost a year now. I just happened to find this while doing a search to see if anyone had gotten it to compile against newer libs.