Bug #21639 Add Replication Delay parameter
Submitted: 14 Aug 2006 23:06 Modified: 27 Jun 2007 13:15
Reporter: Jason Garrett Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S4 (Feature request)
Version:5.x OS:Any (any)
Assigned to:
Tags: Delay, latency, replication
Triage: D5 (Feature request)

[14 Aug 2006 23:06] Jason Garrett
Description:
Provide a parameter/setting which allows an administrator to specify how many seconds a replication slave will be behind a replication master.
This will have the effect of delaying the replcation slave for this number of seconds.

This is useful in circumstances where the replication master is at risk of major data change/loss, and allow an administrator to intervene and isolate the slave from the impact.  
ie.  In an environment where an adminstrator may accidentally drop a table.

How to repeat:
This is a feature request.
[16 Aug 2006 0:40] Arjen Lentz
IMHO this is a brilliant idea!
Lars, Guilhem, what do you think? This should be pretty easy to implement too.
[28 Aug 2006 11:11] Valerii Kravchuk
Thank you for a reasonable feature request.
[8 Sep 2006 10:24] Valerii Kravchuk
Bug #22072 was marked as a duplicate of this one.
[15 Mar 2007 15:54] Marcel Kirsch
This is exactly the feature I missed all the time. I really hope that it becomes reality soon.
[25 Jun 2007 7:42] Anders Henke
http://rodolphe.jouannet.free.fr/dlslaved.html

... implements this feature as a seperate daemon, seperated from mysqld.

However, it's more accurate and nicer to have it in mysqld.
Beside this, the feature simply would be marketing-advertisable if it was implemented within mysqld.
[27 Jun 2007 13:15] Sergei Golubchik
a duplicate of bug#28760 (which already has a patch proposed)