Bug #2149 wait_timeout in my.cnf ignored
Submitted: 18 Dec 2003 1:46 Modified: 22 Dec 2003 2:15
Reporter: Georg Richter Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.2 + 4.0.16 OS:Linux (Linux)
Assigned to: Konstantin Osipov CPU Architecture:Any

[18 Dec 2003 1:46] Georg Richter
Description:
Martin Schneider <cangoou@yahoo.de> reported the following bug on german newsgroup ( I 
was able to reproduce it on 4.1.2, in 3.23.59-debug it works fine): 
 
setting wait_timeout in my.cnf doesn't work 
 
my.cnf: 
wait_timeout=86400 
 
after starting mysqld: 
mysql> show variables like 'wait_time%'; 
+---------------+-------+ 
| Variable_name | Value | 
+---------------+-------+ 
| wait_timeout  | 28800 | 
+---------------+-------+ 
1 row in set (0.03 sec) 
 
set @@wait_timeout works fine. 

How to repeat:
see above
[18 Dec 2003 6:39] Sinisa Milivojevic
Can't repeat with neither 4.0.17 nor 4.1.2.

Here is excerpt from /etc/my.cnf:

[mysqld]
wait_timeout=86400

and here are excerpts from SHOW VARIABLES:

| wait_timeout                    | 86400                                  |

and

| wait_timeout                    | 86400                                  |
[18 Dec 2003 14:09] Georg Richter
tested with C and PHP:

SHOW VARIABLES LIKE 'wait%' => 86400

MySQL command line client:

SHOW VARIABLES LIKE 'wait%' => 28800
SHOW GLOBAL VARIABLES LIKE 'wait%' => 86400

from irc log:

<konstantin>   if (thd->client_capabilities & CLIENT_INTERACTIVE)
<konstantin>     thd->variables.net_wait_timeout= thd->variables.net_interactive_timeout;

this obviously means that mysql command line client uses now CLIENT_INTERACTIVE connect option (which differs from 3.23 and is not documented).

From my view it's not a bug but should be documented.
[19 Dec 2003 4:06] Sinisa Milivojevic
I agree.

I am sending a description to docs-requests@ for better documentation.