Bug #21285 Unable to add MFC consumer class with VS 2003 .Net
Submitted: 25 Jul 2006 20:54 Modified: 1 Aug 2007 22:16
Reporter: Ingar Pedersen Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51.12 OS:Microsoft Windows (Windows Server 2003 R2)
Assigned to: Jess Balint CPU Architecture:Any
Tags: consumer class wizard, ODBC, Visual studio 2003

[25 Jul 2006 20:54] Ingar Pedersen
Description:
In VS 2003 .Net in a VC++ project when trying to add a MFC consumer class, the dialog where all tables are listed doesn't show up after selecting the data source.

If using 3.51.11-2 the table selection dialog is displayed, and the class is generated as expected.

How to repeat:
In class view select Add class, and select a MFC consumer class. Select a data source, and confirm the datasource login. The ODBC dialog disappears, but no table selection dialog appears.

Suggested fix:
Use myODBC 3.51.11-2
[26 Jul 2006 14:14] MySQL Verification Team
Thank you for the bug report.
[10 Oct 2006 17:05] Dan Vachon
I'm having the same problem.  I know it was working with an older version of the Connector / ODBC Driver but I don't know what version it was.  When using the Class Wizard, the Connector window appears, and I attempt to choose a database, I get the following error:

Loading database list not implemented for SQLDriverConnect()

I hope there's a solution.
[17 Oct 2006 14:37] Jonathan Pannaman
I am having the same problem exactly as described.

Does anyone know where to get an older working version or better yet a workaround/fix for the latest version.

Thanks
[9 Jan 2007 13:00] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=25473 was marked as duplicate of
this one.
[1 Aug 2007 18:34] MySQL Verification Team
Trying to get table list

Attachment: getting-table-list.png (image/png, text), 51.47 KiB.

[1 Aug 2007 22:16] MySQL Verification Team
There is the setup flag option Return Tables Names For SQLDescribeCol, so I am closing this bug.