Bug #21242 im_options test is non-deterministic
Submitted: 23 Jul 2006 23:29 Modified: 23 Jul 2006 23:33
Reporter: Stewart Smith Email Updates:
Status: Duplicate Impact on me:
None 
Category:Instance Manager Severity:S1 (Critical)
Version:5.1.12-bk OS:
Assigned to: CPU Architecture:Any

[23 Jul 2006 23:29] Stewart Smith
Description:
When running im_options, it will sometimes fail with:

-------------------------------------------------------
*** r/im_options.result 2006-06-28 11:13:44.000000000 +0300
--- r/im_options.reject 2006-07-24 02:22:03.316783750 +0300
***************
*** 7,13 ****
  server_id     1
  SHOW INSTANCES;
  instance_name state
! mysqld1       starting
  mysqld2       offline
  UNSET mysqld1.server_id;
  ERROR HY000: The instance is active. Stop the instance first
--- 7,13 ----
  server_id     1
  SHOW INSTANCES;
  instance_name state
! mysqld1       online
  mysqld2       offline
  UNSET mysqld1.server_id;
  ERROR HY000: The instance is active. Stop the instance first
-------------------------------------------------------

If the machine is more loaded, the test will pass. I assume this is because it takes longer for mysqld1 to start

How to repeat:
run im_options test when machine is idle.
run im_options test when machine is more loaded

Suggested fix:
allow starting or online in results, or wait for started
[23 Jul 2006 23:33] Stewart Smith
duplicate of 21242