Bug #20978 mysql_upgrade fails due to improper call of mysqlcheck
Submitted: 11 Jul 2006 22:50 Modified: 11 Jul 2006 22:55
Reporter: Armin Schöffmann (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.0.23 OS:Microsoft Windows (win xp sp2 de)
Assigned to: CPU Architecture:Any

[11 Jul 2006 22:50] Armin Schöffmann
Description:
when called with the below parameters, mysql_upgrade fails on windows xp sp de:

mysql_upgrade --basedir="C:\Programme\MySQL 5.0"

direct call of mysqlcheck with appropriate parameters does the job as exspected
e.g.

C:\Programme\MySQL 5.0\bin>mysqlcheck --check-upgrade --all-databases --auto-rep
air --user=root

How to repeat:
C:\Programme\MySQL 5.0\bin>mysql_upgrade --basedir="C:\Programme\MySQL 5.0"
Der Befehl "C:\Programme\MySQL" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
Error executing 'C:\Programme\MySQL 5.0\bin\mysqlcheck --check-upgrade --all-dat
abases --auto-repair --user=root'

Suggested fix:
within mysql_upgrade call mysqlcheck with a fully qualified path (just add an .exe to the string constant :-) )...
[11 Jul 2006 22:53] Armin Schöffmann
OK,
applies to report id# 20950.
sorry for the duplicate report.
[11 Jul 2006 22:56] Miguel Solorzano
Thank you for the bug report. Duplicate of bug:
http://bugs.mysql.com/bug.php?id=20950