Bug #20860 error 2341: 'Internal program error (failed ndbrequire)
Submitted: 5 Jul 2006 6:23 Modified: 6 Sep 2006 10:29
Reporter: David Abbott Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:5.0.22 OS:Linux (Red Hat Linux ES4)
Assigned to: Jonas Oreland CPU Architecture:Any

[5 Jul 2006 6:23] David Abbott
Description:
A development cluster was being used on 2 servers, which both suffered a power outage. The second server required hardware diags, so as this was just a dev
cluster we attempted to restart the cluster with just the one ndbd node.

Repeated attempts failed to start the cluster, requiring us to use ndbd --initial
and rebuild.

The cluster config is attached - but clearly not recommended given it was a 
dev cluster ! However, logs suggested reporting a bug, so here goes, with full
logs/stack traces attached.

Error from cluster log was -

2006-06-29 12:03:58 [MgmSrvr] ALERT    -- Node 2: Forced node shutdown completed
. Occured during startphase 4. Initiated by signal 0. Caused by error 2341: 'Int
ernal program error (failed ndbrequire)(Internal error, programming error or mis
sing error message, please report a bug). Temporary error

How to repeat:
N/A
[5 Jul 2006 6:24] David Abbott
config.ini

Attachment: config.ini (application/octet-stream, text), 950 bytes.

[5 Jul 2006 6:25] David Abbott
ndbd logs/traces

Attachment: ndblogs.tgz (application/octet-stream, text), 68.17 KiB.

[5 Jul 2006 6:25] David Abbott
cluster log file

Attachment: ndb_1_cluster.log (application/octet-stream, text), 7.21 KiB.

[5 Jul 2006 13:27] Miguel Solorzano
Changing to Category: Cluster
[6 Jul 2006 13:42] Jonas Oreland
Hi,

The tracefiles indicates that the filesystem has been corrupted by power outage.
More specifically a schema file with checkpoint info.
These files are written in 2 copies but they seem to be corrupted the both of them

The error message can however be a bit more clear...
[6 Jul 2006 13:51] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/8828
[1 Sep 2006 8:06] Jonas Oreland
pushed to 5.1.12
[1 Sep 2006 19:25] Jonas Oreland
pushed to 5.0.25
[6 Sep 2006 10:29] Jon Stephens
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html

Documented bugfix in 5.0.25 and 5.1.12 changelogs.