Bug #20712 Please implement "with" statement
Submitted: 27 Jun 2006 1:13 Modified: 1 Oct 2009 22:04
Reporter: avi weiss Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: DML Severity:S4 (Feature request)
Version:5.1.9 OS:Microsoft Windows (windows)
Assigned to: CPU Architecture:Any
Triage: Triaged: D5 (Feature request)

[27 Jun 2006 1:13] avi weiss
Description:
we do lots of self referencing joins to add hierarchal performance, and could really use the "with" statement in order to have variable-level hierarchal depths without having to know the level apriori, or add "level indicator" columns in to the table.

How to repeat:
no repeat.
[29 Jun 2006 13:17] Valeriy Kravchuk
Thank you for a reasonable feature request. This surely will be implemented some day.
[1 Oct 2009 22:04] Peter Gulutzan
Duplicate of Bug#16244 SQL-99 Derived table WITH clause (CTE)
[7 Mar 2014 16:42] Jan Steinman
I am currently implementing breeding records for livestock, and am finding it impossible to do arbitrary blood-line reports. Proper implementation of SQL:1999 WITH RECURSIVE would allow me to do so!

Thanks for all your hard work!
[9 Sep 2015 20:07] K Miesse
The lack of Common Table Expressions and recursion is a great hindrance in moving to the MySQL platform. Please implement this ASAP!