Bug #2044 Test suite not included with Windows binary distribution
Submitted: 8 Dec 2003 6:31 Modified: 8 Dec 2003 10:09
Reporter: Georg Scheidel Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.0 OS:Microsoft Windows (Windows)
Assigned to: Bugs System CPU Architecture:Any

[8 Dec 2003 6:31] Georg Scheidel
Description:

Please refer to:
http://www.mysql.com/doc/en/running_mysqltest.html

None of the files mentioned in the following text are contained in the binary distribution packet for Windows, contrary to the statement on the documentation page:

The test system consist of a test language interpreter (mysqltest), a shell script to run all tests(mysql-test-run), the actual test cases written in a special test language, and their expected results. To run the test suite on your system after a build, type make test or mysql-test/mysql-test-run from the source root. If you have installed a binary distribution, cd to the install root (eg. /usr/local/mysql), and do scripts/mysql-test-run. All tests should succeed. If not, you should try to find out why and report the problem if this is a bug in MySQL. 

How to repeat:
Please refer to:
http://www.mysql.com/doc/en/running_mysqltest.html

Download and install the binary distribution packet for Windows ver. 4.0.

search for the above mentioned filed.

Suggested fix:
include the test suite in the binary distribution packet!
[8 Dec 2003 9:15] Miguel Solorzano
Thank for the bug report. 
Greg please take a look.
[8 Dec 2003 10:09] Greg Weir
Our current suite of verification tests is not shipped with the native Windows binaries because it 
cannot be used in a native Windows environment. (The test suite does, however, work under 
Cygwin with server binaries compiled under Cygwin) 
 
A native Windows capable test suite is being worked on, and will be shipped with the Windows 
distributions as soon as it is available. Thank you for your patience.
[8 Dec 2003 10:24] Paul Dubois
Well, there is at least a small doc issue here.  I don't see
that the manual mentions that the test suite is Unix-only.
I'll add a note to that effect.