Bug #20419 ndbd --nowait-nodes=<id_of_running_node> fails with bad error message
Submitted: 13 Jun 2006 9:33 Modified: 8 Jul 2006 7:34
Reporter: Hartmut Holzgraefe Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:5.0.21 OS:Linux (linux)
Assigned to: Tomas Ulin CPU Architecture:Any

[13 Jun 2006 9:33] Hartmut Holzgraefe
Description:
When trying to start a node with --nowait-nodes="id of a running node"
i consistantly get 

Node 3: Forced node shutdown completed. Occured during startphase 5. Initiated by signal 6. Caused by error 2305: 'Arbitrator shutdown, please investigate error(s) on other node(s)(Arbitration error). Temporary error, restart node'.

error messages and the node refuses to start.

How to repeat:
- Set up a cluster with two ndbd nodes
- stop one of the data nodes
- restart the stopped node with command line argument --nowait-nodes="<nodeid of the other node>"
[5 Jul 2006 16:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/8785
[7 Jul 2006 14:36] Tomas Ulin
better error message from 5.0.24 and 5.1.12

please file the request for supporting initial partial start without nowait-nodes as a separate bug
[8 Jul 2006 7:34] Jon Stephens
Documented bugfix in 5.0.24/5.1.12 changelogs.
[13 Jul 2006 3:26] Paul Dubois
5.0.x fix went to 5.0.25 instead.