Bug #20394 To much extraneous functionality and related documentation
Submitted: 12 Jun 2006 13:10 Modified: 29 Mar 2015 4:55
Reporter: Keith Roberts Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:5.0.19 OS:Linux (SuSe Linux 9.2 pro)
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[12 Jun 2006 13:10] Keith Roberts
Description:
Hi all. Thankyou for the excellent job you are doing with mysql and the associated tools.
I would like to propose the following to reduce the learning-curve for mysql server and the associated programs.

Please can we just have one simple SQL command to perfom one function directly from the mysql server, whether this be via mysql monitor, or another linked interface?

For things that need to be done on the command line from supporting programs, please can we have one program to perfrom that functionality, and not repeat it in other programs please?

I would like to see the mysql support programs slimmed down, and the associated documentation culled from the manual.

I recently downloaded postgreSQL and have been playing around with that.

I'm very pleasantly surprised at how simple the documentation for postgreSQL is, compared to mysql's. (I'm hoping to get my head around the whole of the postgreSQL manual by the end of August this year).

I realise that there is clustering and replication, and all the different storage engines to document, which obviously has to be documented.

The point I'm trying to make is I find it very confusing with trying to remember which command I want, when it can be run from a different support program.

Also, when doing things like creating or dropping indexes, for example, could we have just one way to accomplish this please, rather than via ALTER TABLE or the CREATE INDEX syntax please?

I really like the stepping option in psql -s that allows you to step through a file of SQL commands one at a time, and watch the relevant output in the sql monitor program. That would work very well in mysql.

When starting the server, could we just have one program to do every available option, rather than the several programs to choose from please, as I find this section of the manual very daunting

Also the server configuration sections for the my.cnf could do with tidying up please i.e. just one section-name for the server would be quite sufficient.

5.4. MySQL Server Startup Programs

5.4.1. mysqld_safe — MySQL Server Startup Script
5.4.2. mysql.server — MySQL Server Startup Script
5.4.3. mysqld_multi — Manage Multiple MySQL Servers

This section describes several programs that are used to start mysqld, the MySQL server. 

Thankyou for reading!

I look forward to a lean and mean mysql version 6.0.x

Keith Roberts

How to repeat:
Just take a look at relevant sections of the manual, or the help options for some of the support programs.

Suggested fix:
Remove the repeated functionality from mysql server commands, and the supporting programs, and the manual.
[13 Jun 2006 10:07] Valeriy Kravchuk
Thank you for numerous feature requests and documentation requests. Please, remember about existing customers/scripts/backward compatibility issues. If we'll do like you suggested:

"Remove the repeated functionality from mysql server commands, and the manual."

we'll get hundreds of unsatisfied customers immediately.

I agree that it can be difficult to absorb all the ways and features, but simple + incompatible new version is not an option. At least, for versions 5.x.y.

This is a long process, and nobody can tell you definitly if any of the problems you mentioned will be eventually solved.
[13 Jun 2006 13:41] Keith Roberts
Thankyou for your reply Valeriy. I agree with you that this could take some time to implement, which is why I proposed the changes for version 6.0.x not version 5.x.x.

Is there any way to split the current development tree so that you can begin to implement these changes in a pre-release 6.0.x branch of the server code without breaking backward incompatibility?

Perhaps one branch could be the currrent 5.x.x branch, and the other could be a pre-release 6.0.x branch not yet released until all the changes have been implemented in pre-release 6.0.x version, and it is ready to be released as the current version?

This would give you plenty of time to implement the proposed changes into mysql version 6.0.x without upsetting your current user base.

The reason for these changes is to make the learning curve for mysql as easy as possible, without loosing any of the required functionality. I'm sure in the long term this would be of benefit to mysql AB and their user base.

Kind Regards

Keith Roberts
[29 Mar 2015 4:55] Shane Bester
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.

Tools like MySQL Workbench are invented for the purpose of trying to make it easier to manage schema, configuration, etc.
http://dev.mysql.com/doc/workbench/en/index.html