Bug #20255 Download Documentation Request
Submitted: 4 Jun 2006 4:55 Modified: 8 Jun 2006 19:51
Reporter: Robert Nice Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Documentation Severity:S4 (Feature request)
Version: OS:Linux (Linux x86)
Assigned to: Eric Braswell CPU Architecture:Any

[4 Jun 2006 4:55] Robert Nice
It's pretty much impossible to get the mysql-standard package running with the my-innodb-heavy-4G.cnf file because of the 2GB buffer pool. This is on a 4GB x686 type server.

It seems that the standard release is statically linked to an older version of glibc which won't allow a 2GB malloc. The mysql-max version doesn't seem to have a problem with this, it's either dynamically linked or linked against something newer.

I'm filing this to beg for a big notice on the download page to save other people hours of message board searching looking for an answer to a mysterious malloc failure.

How to repeat:

Suggested fix:
Either dynamically link the standard version, or put a big warning with it.
[5 Jun 2006 7:07] Sveta Smirnova
Please, indicate version of MySQL Server.
[5 Jun 2006 14:38] Robert Nice
I'm guessing any, but I tried it with 5.0.22
[8 Jun 2006 10:51] Sveta Smirnova
Thank you for reasonable feature request. Documentation should be updated.

Max memory limit comes from 32-bit architecture, not from MySQL. MySQL on 64-bit CPU and you can allocate more than 4G to single buffer. But on 32-bit CPU there is same result and for mysqld-max. Server starts, but output of  SHOW ENGINE INNODB STATUS displays what INNODB support turned off.
[8 Jun 2006 19:51] Stefan Hinz
This is not a documentation request. The download pages are maintained by our web team. I'm closing this bug and filing a web request.