Bug #2025 Named Pipe crashes on MySQL (4.1.1 alpha) WinXP
Submitted: 5 Dec 2003 11:21 Modified: 10 Dec 2003 6:23
Reporter: Miguel Solorzano Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:4.1.1-alpha OS:Microsoft Windows (Windows NT-all)
Assigned to: MySQL Verification Team CPU Architecture:Any

[5 Dec 2003 11:21] Miguel Solorzano
Description:
Named Pipe crashes on MySQL (4.1.1 alpha) WinXPI have been unable to get
named pipes to work on mysqld-nt 4.1.1
Alpha(including today's official release). As soon as I attempt a
connect the server crashes. I can't create a debug trace because named
pipes aren't enabled during a --debug. I have "enable-named-pipe" turned
on and my client is connecting with hostname of "." notation. The last
several weeks of bitkeeper source distributions haven't worked for me
either. The last time I can confirm it worked for me was a bitkeeper
source build I did on Sep 2 2003. Does anyone have an Alpha 4.1.1
working with named pipes on WinXP (DELL 2.6ghz, P4, 640mb ram, ServPack
1)?

call stack:

        00000000()      
>       mysqld.exe!net_real_write(st_net * net=0x036ef04c, const char * packet=0x036f5b88, unsigned long len=74)  Line 493 + 0x18       C++
        mysqld.exe!net_flush(st_net * net=0x036ef04c)  Line 233 + 0x1d  C++
        mysqld.exe!net_write_command(st_net * net=0x036ef04c, unsigned char command='
', const char * header=0x008c51a8, unsigned long head_len=0, const char * packet=0x046efe24, unsigned long len=69)  Line 350 + 0x79     C++
        mysqld.exe!check_connection(THD * thd=0x036ef040)  Line 722 + 0x2a      C++
        mysqld.exe!handle_one_connection(void * arg=0x036ef040)  Line 916 + 0x9 C++
        mysqld.exe!pthread_start(void * param=0x036e7fd0)  Line 63 + 0x7        C
        mysqld.exe!_threadstart(void * ptd=0x036f51c8)  Line 173 + 0xd  C
        kernel32.dll!77e6d33b()    

How to repeat:
Start the server with --enable-named-pipe and issue with the client:

mysql -h.

Suggested fix:
Sinisa already sent a suggestion fix.
[10 Dec 2003 6:23] MySQL Verification Team
Fixed in 4.1.2