Bug #20002 Old --with-openssl and --with-yassl options just silently ignored
Submitted: 22 May 2006 16:24 Modified: 9 Jun 2006 16:32
Reporter: Jim Winstead Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.1-bk OS:Any (All)
Assigned to: Magnus Blåudd CPU Architecture:Any

[22 May 2006 16:24] Jim Winstead
Description:
A change was recently made so that there is now only a --with-ssl options for configuring SSL support, instead of the distinct --with-yassl and --with-openssl flags we used to have. The problem is that because ./configure ignores options it does not understand (by design -- it is like that so subpackages can be passed configure options by a top-level configure), you can now easily compile without SSL support now.

How to repeat:
./configure --with-yassl

Suggested fix:
Add handling for --with-yassl and --with-openssl (probably a fatal error message).
[23 May 2006 8:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/6751
[23 May 2006 14:18] Magnus Blåudd
Pushed to 5.1-release
[7 Jun 2006 9:32] Magnus Blåudd
Pushed a fix to 5.1.12 that makes configure return an error when --with-openssl or --with-yassl is passed to configure. The error message indicates that the new switch --with-ssl should be used.
[9 Jun 2006 16:32] Paul Dubois
Noted in 5.1.12 changelog.