Bug #19838 Adding a contributor to a project does not work
Submitted: 16 May 2006 3:09 Modified: 27 Jun 2006 2:23
Reporter: Colin Charles Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Websites: MySQLForge Severity:S3 (Non-critical)
Version: OS:
Assigned to: Colin Charles CPU Architecture:Any

[16 May 2006 3:09] Colin Charles
Description:
Adding a contributor to a project does not work. The Search by name does not
return any results.

http://forge.mysql.com/projects/add-contributor.php

How to repeat:
Select a project and try to add a contributor. Enter your own last name and
observe that the search returns emtpyhanded.

Suggested fix:
Fix the search so it actually finds names  ;)
[16 May 2006 3:09] Colin Charles
From jay:
OK, I think this is another one of those user interface gotchas.  The 
search actually does work; the problem is that unless someone has 
specifically been added as a *contributor* (not just a forge user), 
their name won't be found.  There is a table which stored contributor 
information and a table which stores forge user information, so that 
people can be added as contributors without actually having to be a 
Forge User.  When you add a project and check that you are an 
"Administrator", you automatically become a contributor, and your name 
will appear in the returned search list.

I think it's confusing, so what I will do is change the search to look 
for both Forge Users *and* contributors...
[16 May 2006 13:10] Miguel Solorzano
Thank you for the bug report. Yes I agree with you it is confusing and the
search to look for both Forge Users *and* contributors would be more
suitable.
[16 May 2006 13:14] Colin Charles
so the MySQLForge bugs seem to be task trackers (public) for Jay and me. Thanks for verifying!
[27 Jun 2006 2:23] Jay Pipes
Contributor schema was flawed from the beginning.  r44 changes tok care of this bug, since now the process is handled through a request for membership in a project, with an administrator approving the request.