Bug #19769 Access Violation & Processor Hungry
Submitted: 12 May 2006 13:14 Modified: 21 May 2006 12:06
Reporter: Sean Pearce Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:MySQL 4.1.14-nt OS:Microsoft Windows (Windows 2000 SP4)
Assigned to: CPU Architecture:Any

[12 May 2006 13:14] Sean Pearce
Description:
1. When I open MySQL Query Browser, after entering the correct login information, my CPU usage goes to 100% and stays there. 

2. On the status bar at the bottom I am shown the following message: "Access violation at address 005B5358 in module 'MySqlQueryBrowser.exe'. Read of address 00000000".

3. I am unable to click on any menu items, or the close button and there is no context menu when you right click in the window.

4. I am, however, able to double-click a table name in the schemata window and the correct select statement is generated in the SQL window. I am also able to type in the SQL window and in both cases the execute button works, and I receive the correct resultset in the results window.

5. Sometimes, after running a successful query using the above method, the menu system and the right button context menus then work. The CPU though is still at 100% and the error message is still in the status bar.

How to repeat:
Environment
=========
OS: Windows 2000 Service Pack 4
CPU: x86 Family 15 Model 2 Stepping GenuineIntel 2400Mhz
BIOS: Phoenix AwardBIOS v6.00pg

Total Physical Memory: 228,848 Kb
Available Physical Memory: 27,704 Kb
Total Virtual Memory: 780,604 Kb
Available Virtual Memory: 319,532 Kb

MySQL
=====
Version: MySQL 4.1.14-nt via TCP/IP
Client Ver: MySQL Client Version 5.0.4
Query Browser Ver: MySQL Query Browser 1.1.15

Suggested fix:
Not really sure here, but one observation is that the error message in the status bar is flashing at a high rate.
[12 May 2006 13:17] Sean Pearce
Task Manager during the login screen

Attachment: Screen Shot - Before.jpg (image/pjpeg, text), 101.43 KiB.

[12 May 2006 13:18] Sean Pearce
Task Manager after login

Attachment: Screen Shot - After.jpg (image/pjpeg, text), 113.28 KiB.

[12 May 2006 13:33] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with anewer version of server (4.1.19) and QQuery Browser (1.1.20), and inform about the results.
[16 May 2006 7:45] Sean Pearce
I have installed the highest revision of version 4 of MySQL Server (4.1.19), and the latest version of MySQL Query Browser (1.1.20). This has solved the problem, there is no more error message reported on the status bar and the processor is running at normal CPU usage.

Thanks.

This upgrade led to a second bug, which I found the answer to on the forums. When I installed the new version of MySQL Server, the service could not be started with an error of 0. After research on the forums I deleted ib_logfile0, ib_logfile1 & ibdata1 from "C:\<installation directory\data\" and this solved the problem.

I now have a happy MySQL instance.
[21 May 2006 12:06] Valeriy Kravchuk
Problem solved with upgrade.