Bug #19711 WordWrap on text in Notes
Submitted: 11 May 2006 8:14 Modified: 11 May 2006 13:48
Reporter: Stefaan Lesage (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Preview Severity:S3 (Non-critical)
Version:1.0.6 Beta OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[11 May 2006 8:14] Stefaan Lesage
Description:
This is probably a similar report to 19475.

Apparently if you enter text which is larger than what can be displayed on a single line of the note ( text is wider than the canvas of the note ), the text does not get word wrapped, it will simply display the ellipsis ( ... ) where the text is cut off.

Resizing the note doesn't repaint the actual text inside the note.  So if I make my note wider, it will still be cut off where it was before.

Also there is no way to set Word Wrap on a note.  Maybe the text isn't word wrapped by default, but there should be some way to turn it on / off.  Probably using the properties of the note.

How to repeat:
Place a note on the Model.
Type text in the note on a single line, make sure there is too much text on a single line to get displayed in the note.
Text isn't word wrapped.

Suggested fix:
1 ) Add an option to enable / disable word wrapping on notes ( preferably like my suggestion of the Layer's Color make it so this setting can be changed in the properties of the Note ).

2 ) Make sure the text of the note gets repainted / redrawn when the note is resized.
[11 May 2006 13:48] MySQL Verification Team
Thank you for the bug report. Duplicate of bug:
http://bugs.mysql.com/bug.php?id=19475