Bug #19603 compile error caused by specific string of test data in function test_ps_i18n
Submitted: 8 May 2006 8:41 Modified: 13 Oct 2006 19:45
Reporter: Tetsuro Ikeda Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.0.21-win-src/4.1/5.0/5.1 OS:Microsoft Windows (WindowsXP SP2 Japanese Edition)
Assigned to: Iggy Galarza

[8 May 2006 8:41] Tetsuro Ikeda
Description:
I got compile error because "tests/mysql_client_test.c" has special characters for test data.

Followings are snip of the source code.

static void test_ps_i18n()
{
  MYSQL_STMT *stmt;
  int rc;
  const char *stmt_text;
  MYSQL_BIND bind_array[2];

  const char *koi8= "靏, レチ メルツチフヒユ";
  const char *cp1251= "ヘ・ 鈞 矜・・;
  char buf1[16], buf2[16];
  ulong buf1_len, buf2_len;

How to repeat:
See line 10376 of "tests/mysql_client_test.c"

Suggested fix:
Use integer value for each character instead of special character itself.
[8 May 2006 11:35] Miguel Solorzano
Thank you for the bug report.