Bug #19591 MSI Installer Internal Error 2755
Submitted: 7 May 2006 8:37 Modified: 14 Sep 2006 3:33
Reporter: Robin Twiggs Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:mysql-essential-4.1.11-win32.msi OS:Microsoft Windows (Windows)
Assigned to: Iggy Galarza CPU Architecture:Any

[7 May 2006 8:37] Robin Twiggs
Description:
When running "mysql-essential-4.1.11-win32.msi" the following error prevents installation and is reported to the event log:

Event Type:	Error
Event Source:	MsiInstaller
Event Category:	None
Event ID:	10005
Product: MySQL Server 4.1 -- Internal Error 2755. 110, mysql-essential-4.1.11-win32.msi

How to repeat:
With Windows XP:

Right-click "mysql-essential-4.1.11-win32.msi"
Choose Properties
Choose Advanced ( on the General tab which is open by default )
Check "Encrypt Contents to Secure Data"
Choose "OK" and "OK" to encrypt the msi installer.

Run "mysql-essential-4.1.11-win32.msi"
Installation will fail with "Internal Error 2755".

Unencrypt "mysql-essential-4.1.11-win32.msi"
Run "mysql-essential-4.1.11-win32.msi"
Installation succeeds.

Suggested fix:
I'm not sure if there is a fix since the Windows MSI Installer appears to be the problem.

Just reported this as I'm sure others will have a similar problem
- you can encrypt the file unintentionally on downloading it by saving it to a windows folder which is set to encrypt contents of that folder.
[7 May 2006 12:27] Godofredo Miguel Solorzano
Thank you for the bug report. Could you please try the most recent
released version 4.1.19 at:

http://dev.mysql.com/downloads/mysql/4.1.html

Thanks in advance.
[15 May 2006 11:38] Robin Twiggs
I have tested version "mysql-essential-5.0.21-win32.msi" and get a similar error when the msi installer is encrypted by the file system.
[22 Jun 2006 15:56] Godofredo Miguel Solorzano
Thank you for the bug report. I was able to repeat with
mysql-essential-5.0.22-win32.msi too.
[14 Sep 2006 3:33] Iggy Galarza
In order to execute properly, Microsoft installer packages must be unencrypted and installed from an unencrypted directory to an unencrypted directoy.  Please see this link for more information: http://support.microsoft.com/?kbid=83454.