Bug #1952 SHOW TABLE STATUS very slow w/large number of tables
Submitted: 25 Nov 2003 13:49 Modified: 11 Dec 2003 17:26
Reporter: Paul Dubois Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:Any OS:Any (Any)
Assigned to: Dmitry Lenev CPU Architecture:Any

[25 Nov 2003 13:49] Paul Dubois
Description:
Create 20,000 or so MyISAM tables, then try to do SHOW TABLE STATUS
for one of them. Even with a literal table name, the statement will be
very slow to return.

Monty indicates that:

the problem is that the code that read file names allocates blocks in small increments and does in 
this case have to do a LOT of realloc calls

How to repeat:
See above.
[11 Dec 2003 17:26] Dmitry Lenev
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Will be included in the upcoming 4.0.17.