Bug #19380 Binary exits on lauch after error message
Submitted: 26 Apr 2006 17:07 Modified: 9 May 2006 10:08
Reporter: Olivier Clavel Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench Preview Severity:S1 (Critical)
Version:1.0.6beta OS:Linux (Fedora core4 i386)
Assigned to: Alfredo Kojima
Tags: qc

[26 Apr 2006 17:07] Olivier Clavel
Description:
Fedora core 3 i386 with nvidia proprietary driver 8178

This happens with both binary versions I tried (rpm and tar.gz)

When launched from terminal, WB send a warning to stdout:
** (mysql-workbench-bin:5691): WARNING **: Error getting color presets.

An information pop-up appears stating: "The GRT environment for the Workbench could not be initialized. Please verify your installation."

When clicking "OK" application exits

How to repeat:
Install and launch
[26 Apr 2006 18:32] Alfredo Kojima
Please start it as:
export DEBUG=1
mysql-workbench

Then paste the output here.

Thanks
[26 Apr 2006 19:22] Olivier Clavel
[myriam@nomad ~]$ export DEBUG=1
[myriam@nomad ~]$ mysql-workbench
** Message: MySQL Generic Runtime Environment 2.0.12

** Message:
Type 'help' or '?' for help. Type 'quit' to exit the shell.

** Message: Lua Shell initialized.

** Message: Registered 13 struct definitions

** Message: Loading Lua modules...
** Message: Could not load lua module /usr/share/mysql-gui/workbench//lua/Workbench.lua: /usr/share/mysql-gui/workbench//lua/Workbench.lua:1527: malformed number near `9999999999.0'

** Message: Could not load lua module /usr/share/mysql-gui/workbench//lua/WorkbenchImport.lua: /usr/share/mysql-gui/workbench//lua/WorkbenchImport.lua:58: malformed number near `1.5'

** Message: Registered 11 Lua modules

** Message: Initializing C++ loader...
** Message: Registered 0 struct definitions

** Message: C++ loader registration failed (0)
** Message: Could not load lua module /usr/share/mysql-gui/workbench/lua/Workbench.lua: /usr/share/mysql-gui/workbench/lua/Workbench.lua:1527: malformed number near `9999999999.0'

** Message: Could not load lua module /usr/share/mysql-gui/workbench/lua/WorkbenchImport.lua: /usr/share/mysql-gui/workbench/lua/WorkbenchImport.lua:58: malformed number near `1.5'

** Message: Registered 11 modules

** Message: Invalid function calling Workbench.registerEditors
** Message: Invalid function calling Workbench.getColorPresets

** (mysql-workbench-bin:6234): WARNING **: Error getting color presets.
** Message: Invalid function calling Workbench.initWorkbench
[27 Apr 2006 5:31] Alfredo Kojima
Please also paste the output of the env command. Then try to start workbench as:
unset LANG
unset LC_ALL
mysql-workbench
[27 Apr 2006 7:15] Olivier Clavel
Now I get a segmentation fault and the problem looks exactly like the the other bug I filled for fedora core 4 x86_64.... (bug  #19379)
----
[myriam@nomad ~]$ env
OO_SDK_JAVA_HOME=/usr/java/j2sdk
SSH_AGENT_PID=3980
HOSTNAME=nomad.retiz.com
SHELL=/bin/bash
TERM=xterm
HISTSIZE=1000
GTK_RC_FILES=/etc/gtk/gtkrc:/home/myriam/.gtkrc-1.2-gnome2
WINDOWID=41943142
USER=myriam
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
GNOME_KEYRING_SOCKET=/tmp/keyring-erUnBn/socket
SSH_AUTH_SOCK=/tmp/ssh-qNTMkm3936/agent.3936
KDEDIR=/usr
SESSION_MANAGER=local/nomad.retiz.com:/tmp/.ICE-unix/3936
MAIL=/var/spool/mail/myriam
DESKTOP_SESSION=default
PATH=/usr/java/j2sdk/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/myriam/bin
GDM_XSERVER_LOCATION=local
INPUTRC=/etc/inputrc
PWD=/home/myriam
JAVA_HOME=/usr/java/j2sdk
LANG=fr_FR.UTF-8
GDMSESSION=default
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
HOME=/home/myriam
SHLVL=2
GNOME_DESKTOP_SESSION_ID=Default
LOGNAME=myriam
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-xeru5GN5qm,guid=d0624f4479216aa3dceffd3131c16800
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal
XAUTHORITY=/tmp/.gdmmlTwdd
_=/usr/bin/env
[myriam@nomad ~]$ export DEBUG=1
[myriam@nomad ~]$ unset LANG
[myriam@nomad ~]$ unset LC_ALL
[myriam@nomad ~]$ mysql-workbench
** Message: MySQL Generic Runtime Environment 2.0.12

** Message:
Type 'help' or '?' for help. Type 'quit' to exit the shell.

** Message: Lua Shell initialized.

** Message: Registered 13 struct definitions

** Message: Loading Lua modules...
** Message: Registered 13 Lua modules

** Message: Initializing C++ loader...
** Message: Registered 0 struct definitions

** Message: C++ loader registration failed (0)
** Message: Registered 13 modules

/usr/bin/mysql-workbench: line 18: 12351 Erreur de segmentation  $PRG-bin $*
[myriam@nomad ~]$
-----
[27 Apr 2006 11:54] Johan Backlund
Stumbled into the same problem story on standard x86 platform: forcing a locale like en_US fixes the color presets error, but causes a segmentation fault.

Running in gdb gives following stack:

0xb7107aa6 in glViewport () from /usr/lib/opengl/nvidia/lib/libGL.so.1
(gdb) where 10
#0  0xb7107aa6 in glViewport () from /usr/lib/opengl/nvidia/lib/libGL.so.1
#1  0x081ccd53 in CGCView::viewportSet (this=0x86f27c0, newViewport=@0xb56c4b50) at myx_gc_view.cpp:2084
#2  0x08138a36 in MGCanvas::create_view (this=0x86e32b8, view=0x86f27c0) at MGCanvas.cc:865
#3  0x080f7ea4 in MWMainWindow::create_view_in_canvas (this=0x85cc288, view=0x86f27c0) at MWMainWindow.cc:1714
#4  0x080f81b6 in MWMainWindow::handle_message (this=0x85cc288) at MWMainWindow.cc:1758
#5  0x080f3527 in MWMainWindow::view_callback (grt=0x8653830, grtView=0x87ee880, view=0x0, change=3043773264, data=0x85cc288) at MWMainWindow.cc:1025
#6  0x08203e14 in WorkbenchController::notifyView (this=0x86f6b28, view=0x0, change=MYX_WBGC_SWITCHED) at myx_grt_wb_controller.h:118
#7  0x081fa80e in CanvasViewController::realizeView (this=0x88b9d40) at myx_grt_wb_controller.cc:856
#8  0x081fa3ef in CanvasViewController::valueFromGrt (this=0x88b9d40, key=0x88af558 "name", value=0x88af520) at myx_grt_wb_controller.cc:745
#9  0x081f733e in workbench_value_from_grt (param=0x88af520, data=0x0) at myx_grt_wb_bridge.cc:201
(More stack frames follow...)

which seems to suggest that this might be an issue with the nvidia driver (I have 1.0.8756).
[27 Apr 2006 14:57] Alfredo Kojima
Please paste what does "ldd mysql-workbench-bin" show
[27 Apr 2006 19:04] Olivier Clavel
[myriam@nomad ~]$ ldd /usr/bin/mysql-workbench-bin
        linux-gate.so.1 =>  (0x00b11000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00c8c000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00d88000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x05931000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x00834000)
        libnss_files.so.2 => /lib/libnss_files.so.2 (0x00231000)
        libnss_dns.so.2 => /lib/libnss_dns.so.2 (0x00101000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x0010b000)
        libc.so.6 => /lib/libc.so.6 (0x00b34000)
        libglade-2.0.so.0 => /usr/lib/libglade-2.0.so.0 (0x0084b000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x0045b000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x0543f000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x053ac000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00ada000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00af3000)
        libm.so.6 => /lib/libm.so.6 (0x00c5f000)
        libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x05738000)
        libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x05432000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00a71000)
        libdl.so.2 => /lib/libdl.so.2 (0x00c86000)
        libutil.so.1 => /lib/libutil.so.1 (0x00808000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x009a4000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x00120000)
        libGLU.so.1 => /usr/X11R6/lib/libGLU.so.1 (0x001ae000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x05740000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00ca1000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00a14000)
        /lib/ld-linux.so.2 (0x00b12000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00327000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00d9c000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00a0e000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00919000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00a6b000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x00ad0000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x00dfb000)
        libXft.so.2 => /usr/X11R6/lib/libXft.so.2 (0x00a40000)
        libXfixes.so.3 => /usr/X11R6/lib/libXfixes.so.3 (0x00b0b000)
        libXcursor.so.1 => /usr/X11R6/lib/libXcursor.so.1 (0x00a5f000)
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x00a55000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00d77000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00aa9000)
        libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x026f4000)
        libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x00b30000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0574c000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00dda000)
[27 Apr 2006 19:15] Alfredo Kojima
It seems to be indeed caused by the NVidia drivers, try running it as:
LD_LIBRARY_PATH=/usr/X11R6/lib:/usr/lib mysql-workbench

If you do not have libGL.so in /usr/X11R6/lib, please install the following packages from Fedora:
xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2
xorg-x11-Mesa-libGL-6.8.2-1.FC3.45.2_3.rhfc3.at
[9 May 2006 10:08] Olivier Clavel
Workbench works out of the box with no tricks or hacks after I replace the nvidia shipped drivers by the correctly packaged ones from livna. Same solution as in bug #19379 except I don't even have to indicate a library path on this 32 bit version of fedora.
[17 May 2006 8:08] Jérôme Blanc
Hi everyone.
I am having the same problem with a Mandriva 2006 and ATI drivers (8.16.20-4mdk), on an x86_32 system.

Here is the output of the commands previously asked in case it can help : 

[jblanc@jblanc ~]$ export DEBUG=1
[jblanc@jblanc ~]$ env
LESSKEY=/etc/.less
LC_PAPER=fr_FR.UTF-8
MANPATH=:/usr/lib/jdk-1.4.2_09/man:/usr/lib/jdk-1.4.2_09/man
KDE_MULTIHEAD=false
LC_ADDRESS=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
HOSTNAME=jblanc
DM_CONTROL=/var/run/xdmctl
TERM=xterm
SHELL=/bin/bash
LC_SOURCED=1
HISTSIZE=1000
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
GTK2_RC_FILES=/usr/share/themes/Galaxy/gtk-2.0/gtkrc:/etc/gtk-2.0/gtkrc:/home/jblanc/.gtkrc-2.0:/home/jblanc/.kde/share/config/gtkrc-2.0
TMPDIR=/home/jblanc/tmp
GTK_RC_FILES=/usr/share/themes/Galaxy/gtk/gtkrc:/etc/gtk/gtkrc:/home/jblanc/.gtkrc:/home/jblanc/.kde/share/config/gtkrc
DBUS_SESSION_BUS_PID=4609
GS_LIB=/home/jblanc/.fonts
WINDOWID=58720263
LC_NUMERIC=fr_FR.UTF-8
QTDIR=/usr/lib/qt3/
KDE_FULL_SESSION=true
USER=jblanc
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
LC_TELEPHONE=fr_FR.UTF-8
SESSION_MANAGER=local/jblanc:/tmp/.ICE-unix/4770
SCREENDIR=/home/jblanc/tmp
XDG_CONFIG_DIRS=/var/lib/menu-xdg
KONSOLE_DCOP=DCOPRef(konsole-15301,konsole)
NLSPATH=/usr/share/locale/%l/%N
MAIL=/var/spool/mail/jblanc
DESKTOP_SESSION=01KDE
PATH=/usr/bin:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/jdk-1.4.2_09/bin:/usr/share/apps/superkaramba/scripts:/home/jblanc/bin:/usr/lib/ssh:/usr/lib/jdk-1.4.2_09/bin:/usr/share/apps/superkaramba/scripts
LC_MESSAGES=fr_FR.UTF-8
SECURE_LEVEL=2
LC_IDENTIFICATION=fr_FR.UTF-8
LC_COLLATE=fr_FR.UTF-8
KONSOLE_DCOP_SESSION=DCOPRef(konsole-15301,session-8)
INPUTRC=/etc/inputrc
PWD=/home/jblanc
JAVA_HOME=/usr/lib/jdk-1.4.2_09
XMODIFIERS=@im=none
LANG=fr_FR.UTF-8
PYTHONSTARTUP=/etc/pythonrc.py
LC_MEASUREMENT=fr_FR.UTF-8
HISTCONTROL=ignoredups
LESSCHARSET=utf-8
JDK_HOME=/usr/lib/jdk-1.4.2_09
SHLVL=2
HOME=/home/jblanc
LANGUAGE=fr_FR.UTF-8:fr
XCURSOR_THEME=default
GCONF_TMPDIR=/tmp
TMP=/home/jblanc/tmp
LESS=-MM
G_FILENAME_ENCODING=@locale
LOGNAME=jblanc
CVS_RSH=ssh
XDG_DATA_DIRS=/var/lib/menu-xdg:/usr/share
LC_CTYPE=fr_FR.UTF-8
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bCzpo3DqXq
LESSOPEN=|/usr/bin/lesspipe.sh %s
BROWSER=/usr/bin/www-browser
DESKTOP=kde
DISPLAY=:0.0
DEBUG=1
LC_TIME=fr_FR.UTF-8
COLORTERM=
XAUTHORITY=/home/jblanc/.Xauthority
LC_NAME=fr_FR.UTF-8
_=/usr/bin/env
[jblanc@jblanc ~]$ unset LANG
[jblanc@jblanc ~]$ unset LC_ALL
[jblanc@jblanc ~]$ mysql-workbench
** Message: MySQL Generic Runtime Environment 2.0.12

** Message:
Type 'help' or '?' for help. Type 'quit' to exit the shell.

** Message: Lua Shell initialized.

** Message: Registered 13 struct definitions

** Message: Loading Lua modules...
** Message: Could not load lua module /usr/share/mysql-gui/workbench//lua/Workbench.lua: /usr/share/mysql-gui/workbench//lua/Workbench.lua:1527: malformed number near `9999999999.0'

** Message: Could not load lua module /usr/share/mysql-gui/workbench//lua/WorkbenchImport.lua: /usr/share/mysql-gui/workbench//lua/WorkbenchImport.lua:58: malformed number near `1.5'

** Message: Registered 11 Lua modules

** Message: Initializing C++ loader...
** Message: Registered 0 struct definitions

** Message: C++ loader registration failed (0)
** Message: Could not load lua module /usr/share/mysql-gui/workbench/lua/Workbench.lua: /usr/share/mysql-gui/workbench/lua/Workbench.lua:1527: malformed number near `9999999999.0'

** Message: Could not load lua module /usr/share/mysql-gui/workbench/lua/WorkbenchImport.lua: /usr/share/mysql-gui/workbench/lua/WorkbenchImport.lua:58: malformed number near `1.5'

** Message: Registered 11 modules

** Message: Invalid function calling Workbench.registerEditors
** Message: Invalid function calling Workbench.getColorPresets

** (mysql-workbench-bin:22886): WARNING **: Error getting color presets.
** Message: Invalid function calling Workbench.initWorkbench
[17 May 2006 13:49] Alfredo Kojima
JBlanc, Try

export LANGUAGE=C
export LANG=C
Before starting the Workbench.
[8 Jun 2006 11:31] T. M.
I have the same problem.

LD_LIBRARY_PATH doesn't work.
dbExpress drivers or setting LANG and LANGUAGE variabies didn't work neither.

I've tried both: rpm and *.tar version.

Anyone got further ideas?

[Mandriva 2006 Official on Dell D610]
[Aurox Live on Dell D610]
[8 Jun 2006 12:12] T. M.
On Ubuntu 5.10 doesn't work too.
[23 Jul 2006 10:30] [ name withheld ]
The same problem is under OpenSuSE 10 with an Nvidia card.
[19 Oct 2006 19:34] Mauro Casciari
export LANGUAGE=C
export LANG=C

then lanch workbench work fine!

Linux version 2.6.8-11-amd64-k8 Debian Sarge

mysql 5.0.26

Mauro Casciari
[26 Jan 2007 9:29] Sveta Smirnova
Bug #25827 was marked as duplicate of this one.
[17 Oct 2007 12:07] Thierry Marianne
I have solved the same problem by changing in my Workbench.lua

  local lowestX= 999999999.0
  local lowestY= 999999999.0
  local highestX= 0.0
  local highestY= 0.0

with 

  local lowestX= 999999999
  local lowestY= 999999999
  local highestX= 0
  local highestY= 0