Bug #19302 SHOW CREATE TABLE fails with long table definition
Submitted: 24 Apr 2006 16:43 Modified: 14 Sep 2006 9:56
Reporter: Peter Gulutzan Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.1.10-beta-debug OS:Linux (SUSE 10.0)
Assigned to: CPU Architecture:Any

[24 Apr 2006 16:43] Peter Gulutzan
Description:
I have a table with 200 partitions, so the definition is long.
SHOW CREATE TABLE ...\G works fine.
SHOW CREATE TABLE ...; fails.

How to repeat:
create table t1 (s1 int) partition by list (s1) (partition p1 values in (1));

delimiter //

create procedure p1 () begin declare v1 int; set v1 = 2; while v1 < 200 do set @v2 = concat('alter table t1 add partition (partition p',v1,' values in (',v1,'))'); select @v2; prepare stmt1 from @v2; execute stmt1; set v1 = v1 + 1; end while; end//

call p1()//

delimiter ;

show create table t1\G

show create table t1;
[24 Apr 2006 16:55] Miguel Solorzano
Thank you for the bug report. Same with desc table_name and maybe
related to the bug:
http://bugs.mysql.com/bug.php?id=19265
[14 Sep 2006 9:56] Tatiana Azundris Nuernberg
cannot reproduce in 5.1.12