Bug #19241 Can't DROP TRIGGER IF EXISTS or CREATE OR REPLACE TRIGGER
Submitted: 21 Apr 2006 2:40 Modified: 21 Apr 2006 3:00
Reporter: Robin Daugherty Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:5.0.19-standard OS:
Assigned to:
Triage: D5 (Feature request)

[21 Apr 2006 2:40] Robin Daugherty
Description:
MAJOR missing features.  In trying to utilize triggers on production apps, running into serious problems.  I can't provide an update/creation script that simply replaces previous triggers, as I can with procedures and views.

How to repeat:
DROP TRIGGER IF EXISTS <NameOfTrigger>;

CREATE OR REPLACE TRIGGER <NameOfTrigger> AFTER INSERT ON <TableName> <etc.>

Suggested fix:
Add either DROP TRIGGER IF EXISTS or CREATE OR REPLACE TRIGGER to the syntax.
[21 Apr 2006 3:00] Miguel Solorzano
Thank you for the bug report. Duplicate of bug:
http://bugs.mysql.com/bug.php?id=15287 and others.