Bug #19176 2R: MYSQLD core after getting a error 4028 when reading table
Submitted: 18 Apr 2006 19:55 Modified: 20 Apr 2006 9:03
Reporter: Jonathan Miller Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:5.1.10 OS:Linux (Linux 32 Bit OS)
Assigned to:

[18 Apr 2006 19:55] Jonathan Miller
Description:
Stress testing produced:

060418  3:05:28 [ERROR] Got error 4028 when reading table './dbt2/stock'
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=30
max_connections=100
threads_connected=4
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 225791 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0xa364590
Attempting backtrace. You can use the following information to find out
Cannot determine thread, fp=0xb4d9ce04, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x81d0974
0x4bf420
0xb4d9d1e8
0x918492
0x84202f0
0x842900e
0x8227b94
0x8235a31
0x823fa7e
0x8244837
0x8244af9
0x81e9e69
0x81f16e1
0x81f1f3e
0x81f3080
0x81f3437
0xa25b80
0x97d9ce
New value of fp=(nil) failed sanity check, terminating stack trace!
Some pointers may be invalid and cause the dump to abort...
thd->query at 0xa3af9b0 = SELECT i_price, i_name, i_data
FROM item
WHERE i_id = 71148
thd->thread_id=57
mysqld: my_new.cc:51: int __cxa_pure_virtual(): Assertion `"Pure virtual method called." == "Aborted"' failed.
mysqld: my_new.cc:51: int __cxa_pure_virtual(): Assertion `"Pure virtual method called." == "Aborted"' failed.
Fatal signal 6 while backtracing

resolve_stack_dump -s /tmp/mysqld.sym -n ndb08.trace
0x81d0974 handle_segfault + 438
0x4bf420 (?)
0xb4d9d1e8 _end + -1400522512
0x918492 (?)
0x84202f0 my_malloc + 32
0x842900e init_dynamic_array + 154
0x8227b94 _Z19update_ref_and_keysP3THDP16st_dynamic_arrayP13st_join_tablejP4ItemP10COND_EQUALyP13st_select_lex + 206
0x8235a31 _Z20make_join_statisticsP4JOINP13st_table_listP4ItemP16st_dynamic_array + 2187
0x823fa7e _ZN4JOIN8optimizeEv + 1652
0x8244837 _Z12mysql_selectP3THDPPP4ItemP13st_table_listjR4ListIS1_ES2_jP8st_orderSB_S2_SB_mP13select_resultP18st_select_lex_unitP13st_sel + 415
0x8244af9 _Z13handle_selectP3THDP6st_lexP13select_resultm + 309
0x81e9e69 _Z21mysql_execute_commandP3THD + 1877
0x81f16e1 _Z11mysql_parseP3THDPcj + 535
0x81f1f3e _Z16dispatch_command19enum_server_commandP3THDPcj + 1862
0x81f3080 _Z10do_commandP3THD + 260
0x81f3437 handle_one_connection + 725
0xa25b80 (?)
0x97d9ce (?)

How to repeat:
 was currently running the following tests in a 6 host cluster:
1 - cid_ndb_dd.pl - using memory tables - no disk data
4 - tpcb.pl - using mixed data (memory and disk)
1 - DBT2 - using 2 connection with 10 threads each - memory tables
6 - aysnc API programs using memory tables.

Cluster Config:
Host:07 - MySQLD & ndb_mgmd
Host:08 - MySQLD
Host:09 - MySQLD
Host:12 - MySQLD
Host:13 - NDBD & NDBD
Host:14 - NDBD & NDBD

NoOfReplicas: 2
IndexMemory: 500M
DataMemory: 1000M
BackupMemory: 64M
MaxNoOfLocalOperations: 30000
MaxNoOfTables: 100
StopOnError: 1
MaxNoOfConcurrentScans: 100
DataDir: /space/run
FileSystemPath: /space/run
DiskPageBufferMemory: 300M
#DiskPageBufferMemory: 4M
MaxNoOfConcurrentOperations: 30000
NoOfFragmentLogFiles: 50
[18 Apr 2006 19:59] Jonathan Miller
2006-04-18 03:05:27 [MgmSrvr] ALERT    -- Node 5: Node 6 Disconnected
2006-04-18 03:05:27 [MgmSrvr] ALERT    -- Node 5: Node 8 Disconnected
2006-04-18 03:05:28 [MgmSrvr] WARNING  -- Node 2: Node 8 missed heartbeat 4
2006-04-18 03:05:28 [MgmSrvr] ALERT    -- Node 2: Node 8 declared dead due to missed heartbeat
2006-04-18 03:05:28 [MgmSrvr] INFO     -- Node 2: Communication to Node 8 closed
2006-04-18 03:05:28 [MgmSrvr] ALERT    -- Node 2: Node 8 Disconnected
2006-04-18 03:05:30 [MgmSrvr] INFO     -- Node 5: Communication to Node 6 opened
2006-04-18 03:05:30 [MgmSrvr] INFO     -- Node 5: Communication to Node 8 opened
2006-04-18 03:05:31 [MgmSrvr] INFO     -- Node 2: Communication to Node 8 opened
2006-04-18 03:05:33 [MgmSrvr] INFO     -- Node 5: Node 6 Connected
2006-04-18 03:05:33 [MgmSrvr] INFO     -- Node 5: Node 6: API version 5.1.10
2006-04-18 03:05:34 [MgmSrvr] INFO     -- Node 5: Node 8 Connected
2006-04-18 03:05:34 [MgmSrvr] INFO     -- Node 5: Node 8: API version 5.1.10
2006-04-18 03:05:34 [MgmSrvr] INFO     -- Node 2: Node 8 Connected
2006-04-18 03:05:35 [MgmSrvr] INFO     -- Node 2: Node 8: API version 5.1.10
2006-04-18 03:05:38 [MgmSrvr] WARNING  -- Node 4: Node 7 missed heartbeat 2
2006-04-18 03:05:40 [MgmSrvr] WARNING  -- Node 4: Node 7 missed heartbeat 3
2006-04-18 03:05:41 [MgmSrvr] WARNING  -- Node 4: Node 7 missed heartbeat 4
2006-04-18 03:05:41 [MgmSrvr] ALERT    -- Node 4: Node 7 declared dead due to missed heartbeat
[18 Apr 2006 20:05] Jonathan Miller
Note: No node failure found. No error logs or trace files