Bug #19083 ./mysql-test-run.pl starts NDB when it is not needed
Submitted: 13 Apr 2006 18:58 Modified: 10 May 2006 16:56
Reporter: Oleksandr Byelkin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0 OS:Linux (linux)
Assigned to: Jim Winstead CPU Architecture:Any

[13 Apr 2006 18:58] Oleksandr Byelkin
Description:
shell version starts NDB only when it need by test. perl version start NDB every time which take enough time (typing --without-ndb takes time, too)

How to repeat:
./mysql-test-run.pl aliases
[18 Apr 2006 15:18] Magnus Blåudd
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in MySQL.

Additional info:

Duplicate of bug#19167
[18 Apr 2006 15:19] Magnus Blåudd
Description:
mysql-test-run.pl does start NDB even if it's not needed by the test case(s) to
run.

How to repeat:
./mysql-test-run.pl --do-test=alias
 -> Should run the alias test without starting NDB, rpl or IM

or 
./mysql-test-run.pl alias csv
 -> Should run the alias test without starting NDB, rpl or IM

Suggested fix:
When mysql-test-run.pl starts it will "collect testcases", each tests case it
collects will be put into a list togheter with some properties describing what
features it need. The only property right now is "ndb_test". When all tests are
collected, we can just iterate that list and see which features can be disabled.
[21 Apr 2006 2:51] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/5242
[21 Apr 2006 16:47] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/5310
[21 Apr 2006 17:11] Jim Winstead
Approved by Kent via IRC, and Magnus said the additional snapshot changes looked fine.
[1 May 2006 16:03] Jim Winstead
Fixed in 5.0.22 and 5.1.10.
[10 May 2006 16:56] Paul Dubois
Noted in 5.0.22, 5.1.10 changelog.

<command>mysql-test-run.pl</command> started
<literal>NDB</literal> even for test cases that didn't need
it.