Bug #1905 charset and collation usage
Submitted: 20 Nov 2003 12:35 Modified: 11 Dec 2003 10:34
Reporter: Alexander Strashilov Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:4.x OS:Any (all)
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[20 Nov 2003 12:35] Alexander Strashilov
Description:
There is no detail information and examples how to use charset and collation in the CREATE, ALTER , SELECT statements. I think that it should be very usefull for most of the people who developes sites with different charset support.
Also some general information about how to use different character sets on shared hostings where we don't have access to server configuration and files to change the default character set ( which solution is often suggested for problems with sorting and collation).

How to repeat:
Try on a server with latin1 character set to manage cyrillic or other different character set, and test ordering and searching for a part of string...
[20 Nov 2003 12:38] Alexander Strashilov
excuse me for my english
[21 Nov 2003 5:58] Alexander Keremidarski
The problem is that Character Sets and Collation support is changed dramatically between 4.0 and 4.1 while Manual is supposed to cover all versions (currently form 3.23 to 4.1)

At the moment most detailed information you can find at: 

http://www.mysql.com/doc/en/Charset.html
or
http://mysql.online.bg/doc/en/Charset.html if it is closest mirror for you.

There are lot of examples there, but all of them are for 4.1

In 4.0 there is single combo character_set+collation specified as default-character-set with mysqld starting parameter.

The answer on frequently asked question "What to do if I don't have admin access to cahnge mysqld settings?" is

Nothing can be done prior to 4.1

In 4.1 this problem will disappear naturally as you can specify character set and collation per Database, Table and Column level once you have ALTER privilege  on them.

P.S. Don't worry about your English!

Поздрави.
[21 Nov 2003 6:58] Alexander Strashilov
Thank you for your fast answer and for the details also.
So I will patiently wait my provider to upgrade to 4.1.