Bug #18820 Couldn't find MySQL manager or server
Submitted: 5 Apr 2006 19:07 Modified: 3 Jul 2006 15:40
Reporter: Vidhya Padmanabhan Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.0.19 OS:Linux (Linux RedHat Enterprise Ver -4)
Assigned to: CPU Architecture:Any

[5 Apr 2006 19:07] Vidhya Padmanabhan

I am trying to install mysql 5.0 on Linux RedHat Enterprise Ver -4. This OS comes along with mysql 4.0. I have uninstalled all the related files of verison 4.0 and I installed the following files from the mysql website -


I installed them with --nodeps option. After the server standard file installation, the server is trying to start, but it fails giving this error -
Starting MySQLCouldn't find MySQL manager or server

I can't locate the mysql.sock file in the tmp or the /etc/init.d folders. 
If i say mysqld then I return back to the prompt with no error, but any other command like - mysqld_safe, or mysql_install_db (as i read from the bug reports - these commands create the mysql.sock) :
Can't connect to local mysql through socket /var/lib/mysql/mysql.sock
(neither can i see that file)

Please let me know as to what the problem is - do  I need to change the variables in my.cnf file.

How to repeat:
Occurs everytime after installation of the above files and when I try to start mysql
[6 Apr 2006 10:23] Valeriy Kravchuk
Thank you for a problem report. Please, send the results of the foillowing commands:

uname -a
rpm -q -a | grep -i mysql

Do you have SELinux enabled?
[6 Apr 2006 14:46] Vidhya Padmanabhan
These are the results of the operation you had asked -

root@abc ~]# uname -a
Linux cepisprod.coe.uky.edu 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST 2005 i686 i686 i386 GNU/Linux

[root@abc ~]# rpm -q -a | grep -i mysql

I had also tried the solution given in this link - But it hasn't helped.

Someone found it work for RH version 4..

Do I have to undo these changes in my.cnf?

And I do not have SELinux enabled...
(if i give selinuxenabled - I do not get any msg dispalyed)

This problem is holding back a lot of my work... It would be appreciated if someone could help asap...

[6 Apr 2006 14:48] Vidhya Padmanabhan
The version of my.cnf file in my system

Attachment: my.cnf.txt (text/plain), 423 bytes.

[12 May 2006 9:01] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.21, and inform about the results.
[13 May 2006 16:06] Zack Duchene
I have found that when getting the error: "Starting MySQL ERROR! Couldn't find MySQL manager or server" you can go to the /etc/my.cnf file and comment out the basedir and everything will work again.
[9 Jun 2006 14:21] John-Mason Shackelford
I am seeing this bug against mysql  Ver 14.12 Distrib 5.0.22, for pc-linux-gnu (i686) using readline 5.0 on RHEL 4.3
[9 Jun 2006 15:43] John-Mason Shackelford
The workaround described above did not work for us.
[3 Jul 2006 15:40] Valeriy Kravchuk
basedir setting in my.cnf is just wrong for the package installed. That is why removing it solves the problem. See also bug #3233.
[11 Apr 2007 6:37] arun kumar
Solution for mysql Couldn't find the mysql server or manager

[16 Mar 2008 12:14] tom smith
I have tried commenting the basedir in my.cnf on my Redhat AS and it worked for me.
The version I installed was 5.0.51a , earlier I aws using ver 4 which comes with redhat AS
[11 Sep 2009 4:44] gang xiao
In my case, I got this error:
Starting MySQL Couldn't find MySQL manager (/var/lib/bin/mysqlmanager) or server (/var/lib/bin/mysqld_safe)

I found there's no such directory /var/lib/bin, so I made one.Then I search for "mysqlmanager" and "mysqld_safe", and copy them to /var/lib/bin.
After all this, I started mysql service successfully.