Bug #18755 Fatal error when using MyODBC + UNSIGNED BIGINT + DotNet.
Submitted: 3 Apr 2006 19:26 Modified: 11 Sep 2007 18:25
Reporter: d di (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.1 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any

[3 Apr 2006 19:26] d di
Description:
DotNet classes that utilize DataSet, DataAdapter and CommandBuilder's to manipulate data does not work with MyODBC when the table has an UNSIGNED BIGINT column.

The error that occurs is:
 ERROR [07006] [MySQL][ODBC3.51 Driver][mysqld-5.0.18-nt-max]
 Restricted data type attribute violation(SQL_C_NUMERIC)

How to repeat:
I've created a test case which I will attach to this issue in a moment.

Suggested fix:
 * fix MyODBC to do as .NET expects so UNSIGNED BIGINT columns work...

Or the rather poor alternative:
 * document in the Connector/ODBC section of the MySQL manual that UNSIGNED BIGINT doesn't work when using .NET and MyODBC.
[3 Apr 2006 19:29] d di
SQL to create and fill a database for use with test case

Attachment: create18755.sql (application/octet-stream, text), 326 bytes.

[3 Apr 2006 19:29] d di
Test case

Attachment: bug18755.cs (text/plain), 1.59 KiB.

[21 Apr 2006 9:36] Tonci Grgin
Hi. Thanks for your problem report. It seems to be compiler related as in MS article: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/odbc/htm/odbcc_data_types....
We will inform you of our findings.
[24 Apr 2006 5:13] Tonci Grgin
Verified as described by reporter.
[11 Sep 2007 18:25] Jim Winstead
This is a duplicate of Bug #3028. Support for SQL_NUMERIC_STRUCT is scheduled to be implemented in Connector/ODBC 5.1.