Bug #18655 Script tag page: ctrl-enter does not work
Submitted: 30 Mar 2006 16:29 Modified: 23 Nov 2006 14:31
Reporter: David Woods Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.20 OS:Microsoft Windows (windows 2000 pro)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: Generic

[30 Mar 2006 16:29] David Woods
Description:
The keyboard shortcut ctrl-enter to execute a query does not work on the "script" tab page; you must use the "execute" button.  The ctrl-enter shortcut works just fine on a "query" tab page.

How to repeat:
Click File->New Script Tab.  Enter any query.  Press ctrl-enter on the keyboard; nothing happens.  (CLick the "execute" button, it runs.)
[30 Mar 2006 17:37] Miguel Solorzano
Thank you for the bug report. Could you please provide the QB's Version and
OS used. Thanks in advance.
[30 Mar 2006 17:38] David Woods
version & op syst provided, as requested
[30 Mar 2006 17:41] David Woods
version & op syst provided, as requested
[30 Mar 2006 17:55] Miguel Solorzano
Thank you for the bug report.
[23 Nov 2006 14:31] Mike Lischke
This behavior is by design. Use the query area to execute arbitrary SQL commands. The script editor is used to execute entire scripts. This is rather like debugging a computer program, including break points, start over, full run and stepping through the code.