Bug #18590 rpl_switch_stm_row_mixed
Submitted: 28 Mar 2006 22:51 Modified: 13 Jul 2006 4:22
Reporter: Brian Aker Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:5.1 bk OS:Solaris (Solaris 10 AMD64 -max GCC)
Assigned to: Guilhem Bichot CPU Architecture:Any

[28 Mar 2006 22:51] Brian Aker
Description:
Errors are (from /tmp/var-ps_row-6/log/mysqltest-time) :
mysqltest: At line 118: query 'create table t4 select * from t1 where 3 in (select 1 union select 2 union select UUID() union select 3)' failed: 1247: Reference '<result>' not supported (forward reference in item list)
(the last lines may be the most important ones)
Result from queries before failure can be found in r/rpl_switch_stm_row_mixed.log

How to repeat:
https://intranet.mysql.com/~knielsen/getlog.pl?dir=mysql-5.1-new&entry=push reggie@linux.site-20060328185951.info&name=test_ps_row&plat=sol10-amd64-a
[6 Apr 2006 14:14] Lars Thalmann
The report does not indicate if the ps protocol was used, but it seems that 
this is a duplicate of BUG#18492.
[7 Jun 2006 15:04] Lars Thalmann
Need to reenable test case
[7 Jun 2006 15:25] Guilhem Bichot
will re-enable it at once (need it for BUG#19630)
[7 Jun 2006 15:29] Guilhem Bichot
just submitted patch for BUG#19630 for review, that patch includes re-enabling the test
[3 Jul 2006 14:36] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/8646
[3 Jul 2006 14:51] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/8649
[6 Jul 2006 15:55] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/8843
[11 Jul 2006 8:09] Guilhem Bichot
Fixed in 5.1.12. Nothing to document.
ChangeSet
  guilhem@gbichot3.local|ChangeSet|20060706155404|16502    2006/07/06 17:54:04+02:00 guilhem@gbichot3.local +4 -0
  Fix for BUG#20649 "mixed replication mode does not work with INSERT DELAYED".
...
[11 Jul 2006 8:10] Guilhem Bichot
pushed in the replicaton team's tree
[13 Jul 2006 4:22] Paul Dubois
No changelog entry needed.