Bug #18264 WB error when opening another WB
Submitted: 15 Mar 2006 22:01 Modified: 16 Mar 2006 12:04
Reporter: Steve Slater Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Preview Severity:S2 (Serious)
Version:1.0.5 beta OS:Microsoft Windows (win2k)
Assigned to: CPU Architecture:Any

[15 Mar 2006 22:01] Steve Slater
Description:
Get a workbench eror when trying to create another wb with File->New Workbench.

How to repeat:
It works fine when just starting the WB or when making a new one from a blank bench. 

I reverse engineering the test db so I have something in my model. From here, I can still do File-> New workbench.

Once I save the model to disk (or if I open one from disk), whenever that window tries to do a File->New Workbench I get an error pop-up right after the splash screen that says:

The runtime environment (GRT) could not be initialized.

Error Details:
Workbench.initWorkbench :The function did not return an object. Error Nr. 10003

Shell output:
....
Error while loading struct definitions (10001)
....

Error while loading PHP modules (10001)
...
Error while loading Lua modules (10001)
[16 Mar 2006 12:04] MySQL Verification Team
probably a duplicate of http://bugs.mysql.com/bug.php?id=14932 (Crash after saving a scheme and then opening a new workbench)