Bug #18234 rpl* tests crash on OS X
Submitted: 14 Mar 2006 17:30 Modified: 15 Mar 2006 16:47
Reporter: Oleksandr Byelkin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.0 OS:Mac OS X (Mac OS (ppc))
Assigned to: Bugs System CPU Architecture:Any

[14 Mar 2006 17:30] Oleksandr Byelkin
Description:
rpl tests fail:

TEST                            RESULT
-------------------------------------------------------
rpl000001                      [ fail ]

Errors are (from /Users/bell/mysql/bk/work-etalon-5.0/mysql-test/var/log/mysqltest-time) :
mysqltest: At line 15: query 'stop slave' failed: 2013: Lost connection to MySQL server during query
(the last lines may be the most important ones)

Aborting: rpl000001 failed in default mode. To continue, re-run with '--force'.

Ending Tests
Shutting-down MySQL daemon

Master shutdown finished
slave not cooperating with mysqladmin, will try manual kill
./mysql-test-run: line 1556: kill: (5112) - No such process
slave refused to die. Sending SIGKILL
./mysql-test-run: line 1560: kill: (5112) - No such process
Slave shutdown finished

How to repeat:
build with compile-ppc-debug-max
run ./mysql-test-run t/rpl000001.test
[14 Mar 2006 22:40] Elliot Murphy
running the rpl tests, the first test crashes. Federated also crashes, but most likely this is related to replication, not to federated.
[15 Mar 2006 7:39] Greg Lehey
Finger trouble accidentally assigned to Jim Dowling.  Corrected.
[15 Mar 2006 16:47] Elliot Murphy
Duplicate of bug#15671. Oops.