Bug #18228 on line ALTER TABLE operation does not work with engine=ndb
Submitted: 14 Mar 2006 15:53 Modified: 24 Mar 2006 14:10
Reporter: patrice audigou Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:5.1.8-beta OS:Linux (RedHat9)
Assigned to: CPU Architecture:Any

[14 Mar 2006 15:53] patrice audigou
Description:
On line ALTER TABLE  operation (ADD column) causes an exception
on a ndbapi client application. 

 msg:  Table not defined in transaction coordinator.

note:
===
table are created as following :

create table IMSI (
                mykey INT UNSIGNED NOT NULL,
vInt INT,
PRIMARY KEY USING HASH (mykey) ) engine=ndb PARTITION BY KEY (mykey);

How to repeat:
/*---*/
[24 Mar 2006 13:54] Valeriy Kravchuk
Thank you for a problem report. ALTER TABLE works for me in mysql command line client:

openxs@suse:~/dbs/5.1> bin/mysql -uroot test
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 5.1.8-beta-debug

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> create table IMSI (
    ->                 mykey INT UNSIGNED NOT NULL,
    -> vInt INT,
    -> PRIMARY KEY USING HASH (mykey) ) engine=ndb PARTITION BY KEY (mykey);
Query OK, 0 rows affected, 1 warning (0.03 sec)

mysql> alter table IMSI add newcol int;
Query OK, 0 rows affected (0.03 sec)
Records: 0  Duplicates: 0  Warnings: 0

Please, send your ndbapi-based test case.
[24 Mar 2006 14:00] Jonas Oreland
Hi Patrice

Ndb does currently not support online "alter table add column"
Therefor it's expected behaviour that a ndbapi program get error.

The proper way of handling this is to retreive the table again and
  restart your transaction.

/Jonas
[24 Mar 2006 14:03] patrice audigou
schema

Attachment: createtableNew.sql (text/x-sql), 185 bytes.