Bug #18219 Cannot rename Layer elements
Submitted: 14 Mar 2006 11:15 Modified: 28 May 2006 13:37
Reporter: Dan Kelly Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Preview Severity:S1 (Critical)
Version:1.0.5 beta OS:Microsoft Windows (Windows XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any

[14 Mar 2006 11:15] Dan Kelly
Description:
The elements in the Layers tab on the RH of the screen do not change their name and cannot be edited.

1) Tables are created with the default "table_nn" name when a table is created and do not inherit the table name when that is edited in the table properties screen (pen-icon).

2) Table names cannot be edited in the Laters dialog (double- or right-click)

3) Tables created in a new session restart numbering at table_01 - so layers dialog can have multiple tables with the name "table_01".

4) Layers are created with default "New Layer" name.  Name cannot be changed.  Subsequent layers therefore all have the same name.  No way of editing layer names.

Table names are correctly listed in the when "Reverse Engineering" a database.  Changes to names are not reflected in the Layers dialog when Table name is changed

How to repeat:
1) + 2) Create a table as normal.  Change table name in properties.  Table remains as "table_01" in Layers dialog.  Try right/double-click to change name.

3) Create a number of tables in a session. Save session as .mwb file.  Open session and create new table.  New instance of "table_01" will be in the Layers dialog.

4) Select several tables in a layer.  Select second layer - new layer is also named "New Layer"

Suggested fix:
1), 2), 3) Inherit table name from table properties dialog.  Allow direct editing of table names from the Layers dialog. Perhaps open table properties dialog when double clicking Name

4) Allow change of Layer name
[14 Mar 2006 15:17] Dan Kelly
Found out how to edit Layer Names.

Select Layer and change to Properties tab - changes can be made there.  Still no solution for table names.
[4 Apr 2006 16:17] MySQL Verification Team
Thank you for the bug report.
[28 May 2006 13:37] Geert Vanderkelen
Duplicate of #13150.