Bug #1774 Truncated words after double quote
Submitted: 6 Nov 2003 19:35 Modified: 17 Nov 2003 6:34
Reporter: Simon Yu Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / J Severity:S1 (Critical)
Version:3.0.8 OS:Microsoft Windows (windows 2000)
Assigned to: Mark Matthews CPU Architecture:Any

[6 Nov 2003 19:35] Simon Yu
Description:
The problem is that I use the PreparedStatement to update a field, and the value contains double quote ("). After excuting "preparedstatement.executeUpdate(SQLStatement), the words after (") are truncated.

For example:

----------------------------------------------------------------------
String SQLStatement = "insert into table_a values (?)";
PreparedStatement ps = new PreparedStatement(SQLStatement);
ps.setString(1, "The word contains \" character");
ps.executeUpdate();
-----------------------------------------------------------------------

After executing this, the table_a has the value:
"The word contains"

How to repeat:
execute the above program

Suggested fix:
The problem seems to be the JDBC driver
[17 Nov 2003 6:34] Mark Matthews
I am not able to repeat this issue with Connector/J 3.0.9. Also, the code example you give is not valid Java code (i.e. there is no constructor for PreparedStatements).

Please test your code with Connector/J 3.0.9, and if there is still an issue, post a _complete_, repeatable testcase.