Bug #17730 Configuration Wizard Hangs
Submitted: 27 Feb 2006 0:56 Modified: 9 Oct 2010 5:17
Reporter: Michael Nelson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:5.0.18 OS:Microsoft Windows (Windows 2003)
Assigned to: CPU Architecture:Any

[27 Feb 2006 0:56] Michael Nelson
Description:
Installed MySQL on Windows 2003 Server with all latest service packs. (Not RC2).
Installs OK. MySQL service is running. Run configuration wizard and hangs when
EXECUTE button is pressed on last page. No other information is given. No errors in event viewer. Cannot find any error messages in MySQL. 

Tried changing the service account to administrator. Tried setting up a new account. The service stops and starts fine. 

New to MySQL, but cannot see anything wrong with installation.

How to repeat:
Load MySQL on Windows 2003 server and run the configuration wizard. Wizard hangs on last screen.
[27 Feb 2006 1:27] Michael Nelson
4.1 installs and configures on the same server with no problem.
[27 Feb 2006 10:51] Valeriy Kravchuk
Thank you for a problem report. Had you tried to install MySQL as local Administrator? If no, please, uninstall it and try again.

If yes, please, send the results on netstat -a command. I want to check, that port 3306 is not used.
[19 Mar 2006 22:26] Michael Nelson
Results of netstat -a

Attachment: Mysql_netstat.txt (text/plain), 2.14 KiB.

[19 Mar 2006 22:29] Michael Nelson
Yes, I tried to reinstall under administrator and also as a new account with admin rights.

I have uploaded Mysql_netstat.txt which shows the results of netstat -a. It was run when attempting to run the config wizard. The config wizard locks up.

I have also uploaded a screen shot of an error message. I check and Windows Firewall is not running and not configured. I also double checked removal of other data files, etc.
[19 Mar 2006 22:30] Michael Nelson
Screen shot of error and config wizard hang

Attachment: MySQLError.doc (application/msword, text), 55.00 KiB.

[19 Mar 2006 22:58] Michael Nelson
Netstat prior to installation

Attachment: Mysql_netstat_prior.txt (text/plain), 1.88 KiB.

[19 Mar 2006 22:58] Michael Nelson
Netstat after installation

Attachment: Mysql_netstat_afterinstall.txt (text/plain), 1.93 KiB.

[19 Mar 2006 22:59] Michael Nelson
Netstat after installation, during config wizard

Attachment: Mysql_netstat_duringconfig.txt (text/plain), 1.94 KiB.

[19 Mar 2006 23:00] Michael Nelson
With firewall service on but filtering off

Attachment: Mysql_netstat_withfirewallon.txt (text/plain), 2.16 KiB.

[19 Mar 2006 23:00] Michael Nelson
with firewall service on and port 3306 open

Attachment: Mysql_netstat_withfirewallportopen.txt (text/plain), 2.21 KiB.

[19 Mar 2006 23:04] Michael Nelson
I tested several other options. Files are attached:

Netstat before installation.
Netstat after installation.
Netstat after installation, during config wizard hang.

All the above were run windows firewall service disabled.

Windows firewall service was not running. I turned the service on but left firewall off.
Opened port 3306 on windows firewall.
Ran netstat under both circumstances.
[29 Mar 2006 9:42] Vincent Cheung
I also got this problem.

But at the first time installation is no problem and works fine.

I tested, sometimes can't "Start service" and sometimes can't "Apply security settings".
[30 Mar 2006 1:29] Vincent Cheung
I tested if run "Reconfigure Instance" or "Remove Instance" again.
It could not restart the service or apply new settings.
[30 Mar 2006 1:36] Vincent Cheung
Suggestion:
For "Service":
When execute the new settings, stop the service 1st before start.
[30 Mar 2006 1:48] Vincent Cheung
Actually, I'm not hang at configuration wizard.
Just can't start service & apply new security.
At last, I lost the password.
[21 Apr 2006 14:19] Valeriy Kravchuk
Michael,

Please, try to repeat with a newer version, 5.0.20, AND (most important) if you'll get an error message that you can not connect to service, try again (there is a button to repeat). When you create a completely new instance with InnoDB support (as it is by default), service will need some time to initialize InnoDB tablespace and logs, and MySQL server will not accept connection (to apply security settings) during this process. So, trying again after several seconds can (and, in many know cases, do) help.
[25 Apr 2006 7:34] Vincent Cheung
But 5.0.20 does not fix my proved problems BUG#18638.
[21 May 2006 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[23 May 2006 1:24] Vincent Cheung
I will never use/test MySQL again.
I rather pay money to use MSSQL / Oracle. Bye Bye.
[7 Oct 2009 21:02] laxman e
I am also downloaded the mysql-essential-5.1.39-win32 file and started installation. Unfortunately, wizard is locked without performing any task mentioned in the wizard.(i.e. Prepare configuration, write configuration file, etc).
I dont know what to do?
any help on this.
[13 Oct 2009 14:23] Richard Stoffer
Same over here!

I was also 100% percent positive about mysql as the solution for many, but this issue is causing me too much stress.

Still no news about this issue?
[27 Oct 2009 19:18] laxman e
unfortunately no reply mysql. I tried uninstalling and installing but no luck.
[27 Oct 2009 19:20] laxman e
wizard is sucessfull if you dont enter any user id and password for server.
Next problem is, when I launch mysql administrator, it will give another user error.
[17 Nov 2009 21:14] Thomas Riddle
I have the same issue. Configuration wizard hangs when trying to start the service. What a piece of crap.
[17 Nov 2009 21:25] Richard Stoffer
After too much time and frustrations I found out that XAMPP did the job for me. Instead of tweaking and twisting your registry just install XAMPP and just use the services you want (I only use MySQL and FTP services). Ofcourse you might need to alter your log size for better performance.
[31 Dec 2009 5:48] m c
I had the same problem on Windows 2008. The configurator just hangs without performing any of the steps. On my fourth try it ran successfully, and the only change I made was to change the initial root password from 'admin' to 'hello'. So possibly MySQL doesn't like 'admin' as a password is the only thing that makes sense to me.
[2 May 2010 9:55] Jakob Schttl
I have the same problem on Win XP Prof SP 3. The wizard hangs on the last page after I press execute (the first 2/4 items are applied, but then it hangs).
[3 May 2010 20:11] ales allesio
hi, well i had the same problem ....
well solution for me was that i changed installation dir:
ex: C:\mySql\MysqlServer5.x.x to C:\MySql\MySqlServer5
[9 May 2010 12:21] Jakob Schttl
Thank you, ales allesio.
I changed the installation-directory and now it works.
[7 Sep 2010 12:57] Martijn Cerutti
Greetings, I've had the same problem on both Windows 7 and Windows Server 2003. I came across this thread, and thought I'd mess around a bit, which ended up being an hour and a half. However, I think I have found the solution to the problem.

The problem is with InnoDB, if it has initialized before, the second time it won't be able to, since one of its files is not zero-sized, and therefore its constructor will throw an exception, causing the configuration wizard to freeze.

The InnoDB rubbish is located in "C:\ProgramData\MySQL\MySQL Server 5.1\data" by default, and there will be a {machine name}.err file in there. If you open that in notepad and find an error message saying that, the solution is to simply uninstall MySQL, and remove that folder in its entity after you have uninstalled.

So basically, uninstall, remove the "C:\ProgramData\MySQL\" folder entirely, and reinstall. After doing that, the configuration utility did not freeze anymore on my two machines, and MySQL is now properly running.

Hope that helps!
Regards.
[9 Oct 2010 5:17] Sveta Smirnova
Martijn,

your problem is duplicate of bug #56851
[24 Nov 2010 6:43] jerald m
Please help me
after installation mysql 5.1.53
mysql server instance configuration in last step after clicking execute 
it hangs in start service.
i cleared register key with ccleaner,
i tried with firwall Off.
still i'm not getting it.
[24 Nov 2010 6:49] jerald m
Hi,
I am using Windows Vista. Today I installed MySql.When I run Mysql Server Instance Configuration Wizard, it gets stuck at "Start service" and did not throw any error.
Please Help me...
[24 Nov 2010 9:03] Jakob Schttl
@jerald m
Did you try to change the installation directory, as here discripted?
[24 Nov 2010 11:30] jerald m
thank you i changed installation directory it works :-)
[13 Dec 2010 6:45] Henry Lauer
I think I am having the same problem: config wizard gets to the "execute" page. As soon as I click execute it freezes.

Have tried the trick with manually deleting directories but it has not yielded any joy :(

Thoughts?
[13 Dec 2010 19:24] Jakob Schttl
@Henry Lauer
Did you read some posts here?
once again:
Did you try to change the installation directory, as here suggested?
[13 Dec 2010 20:31] Henry Lauer
Thanks for you help...but it doesn't seem to help when I install to another directory than the default (that is what is meant, right?)
[13 Dec 2010 21:10] Jakob Schttl
yes, just another directory than the failed attemps before... works for some
[15 Dec 2010 15:05] Fabien Le Grand
I had this problem today. We solved it by removing the folder in : C:\Documents and Settings\All Users\Application Data\MySQL

Good Luck.
[31 Jan 2011 23:22] Dan C
This bug still exists, even on 5.5.

If you have installed then uninstalled mysql, the next install will never successfully start service in the wizard.

Deleting mysql folder from program files before installation does not help.

Deleting %ALLUSERSPROFILE%\application data\mysql before installation fixed the problem for me.
[16 Sep 2011 14:53] Jan Lucas
I tried all of the above and it still didn't work.

THEN I tried all of the above AND removed all references to MySql from the registry - and it worked!
[6 Nov 2011 11:20] Roman Zubarev
At the end of the mysql installation, uncheck Start the Instance Wizard.
Then go to wherever you installed mysql/bin and start the Instance Wizard as an Administrator. Solved it for me.
[2 Jan 2012 13:47] alex edwards
I tried many combinations of the above and none solved my problem. What finally solved it for me was cleaning the registry, I couldn't find the registry key mentioned above but I have had mysql installed standalone and as part of Xampp. I used Ccleaner's registry tool.
[4 Oct 2012 6:45] Marko Mäkelä
This really is a duplicate of Bug#13494, which will be fixed in MySQL 5.6.8.