Bug #17719 Delete of binlog files fails on Windows
Submitted: 26 Feb 2006 1:28 Modified: 28 Jun 2006 16:39
Reporter: Kent Boortz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.1.7-beta OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any
Tags: binlog

[26 Feb 2006 1:28] Kent Boortz
Description:
The following list of test cases fails with the same difference.
The failure to delete the binlog is just a warning, should be
an error, or is this not critical?

Suite timed out, list might not be complete

rpl000011                      [ fail ]
rpl000017                      [ fail ]
rpl_alter                      [ fail ]
rpl_bit_npk                    [ fail ]
rpl_commit_after_flush         [ fail ]
rpl_delete_no_where            [ fail ]
rpl_drop                       [ fail ]
rpl_drop_temp                  [ fail ]
rpl_err_ignoredtable           [ fail ]
rpl_free_items                 [ fail ]
rpl_ignore_grant               [ fail ]
rpl_ignore_table               [ fail ]
rpl_init_slave                 [ fail ]
rpl_insert_id                  [ fail ]
rpl_insert_ignore              [ fail ]

  stop slave;
  drop table if exists t1,t2,t3,t4,t5,t6,t7,t8,t9;
  reset master;
+ Warnings:
+ Error 6       Error on delete of 'e:\build\mysql-5.1.7-beta-build\mysql-5.1.7-beta\mysql-test\var\log\master-bin.000001' (Errcode: 13)

How to repeat:
Run mysql-test-run.pl on Windows
[1 Mar 2006 11:31] Valeriy Kravchuk
Verified just as described.
[9 Mar 2006 13:11] Elliot Murphy
Some additional details from my testing:

I downloaded 5.1.7-beta source, built on Windows, and started a debug server using the binary log. I attached a debugger, watched what happens during reset master - all the files were deleted without error.

I've not yet been able to run one of the affected tests with mysql-test-run.pl, but so far I have been unable to reproduce the problem outside of mysql-test-run.pl.
[9 Mar 2006 13:47] Elliot Murphy
Progress update:

In order to get the 5.1.7 version of mysql-test-run.pl to work on windows, use this: elliot|sorrento, Add "$glob_basedir/client_debug" to the function "mtr_path_exists()" in "executable_setup"

I chose to use test case rpl_drop in order to track down this bug. Running ./mysql-test-run.pl (in cygwin) --skip-ndb --do-test=rpl_drop, rpl_drop does not show the warning but rpl_drop_db does! Just running rpl_drop_db by itself, the problem does not occur. So, must run more than one rpl test for this bug to manifest.
[21 Mar 2006 18:54] Magnus BlÄudd
Enable testing of "rpl" in PushBuild when this had been fixed.
[13 Apr 2006 5:45] Elliot Murphy
Test case to reproduce failure to delete binlog due to open file handle

Attachment: rpl_drop_a.test (application/octet-stream, text), 1.17 KiB.

[28 Jun 2006 16:39] Lars Thalmann
Duplicate of BUG#19208
[28 Jun 2006 16:44] Lars Thalmann
Duplicate of BUG#19208